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About This Manual
This manual describes Xilinx’s PROM File Formatter program, a
graphical user interface that allows you to create PROM files from
individual Xilinx bitstream files.
Before using this manual, you should be familiar with the operations
that are common to all Xilinx software tool. These operations are
covered in the Quick Start Guide.

Additional Resources
For additional information, go to http://support.xilinx.com. The
following table lists some of the resources you can access from this
page. You can also directly access some of these resources using the
provided URLs.
Resource

Description/URL

Tutorial

Tutorials covering Xilinx design flows, from design entry to verification
and debugging
http://support.xilinx.com/support/techsup/tutorials/index.htm

Answers
Database

Current listing of solution records for the Xilinx software tools
Search this database using the search function at
http://support.xilinx.com/support/searchtd.htm

Application
Notes

Descriptions of device-specific design techniques and approaches
http://support.xilinx.com/apps/appsweb.htm

Data Book

Pages from The Programmable Logic Data Book, which describe devicespecific information on Xilinx device characteristics, including readback, boundary scan, configuration, length count, and debugging
http://support.xilinx.com/partinfo/databook.htm
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Resource

Description/URL

Xcell Journals

Quarterly journals for Xilinx programmable logic users
http://support.xilinx.com/xcell/xcell.htm

Tech Tips

Latest news, design tips, and patch information on the Xilinx design
environment
http://support.xilinx.com/support/techsup/journals/index.htm

Manual Contents
This manual covers the following topics.

ii

•

Chapter 1, “Introduction,” introduces the PROM File Formatter.

•

Chapter 2, “Getting Started,” describes how to start the PROM
File Formatter and use the PROM File Formatter interface. The
chapter also describes the online help tool.

•

Chapter 3, “Using the PROM File Formatter,” explains how to
create a new PROM file and open an existing PROM file, and
how to use the PROM File Formatter to organize the contents of a
new PROM file. The chapter also explains how to define the
properties of your PROM file, retarget a PROM to multiple
PROM devices, and save a PROM file.

•

Chapter 4, “Menu Command Reference,” describes each of the
commands and dialog boxes available from the PROM File
Formatter.

•

Appendix A, “Glossary of Terms,” defines the terms you should
be familiar with to use the PROM File Formatter.

•

Appendix B, “Keyboard Shortcuts,” lists the keyboard keys you
can use as an alternative to the mouse to navigate in the PROM
File Formatter and to select menu commands.

•

Appendix C, “Multiple Configuration Setups,” describes
programming setups that you can use to support multiple
applications in a system.
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Conventions
This manual uses the following conventions. An example illustrates
each convention.

Typographical
The following conventions are used for all documents.
•

Courier font indicates messages, prompts, and program files
that the system displays.
speed grade: -100

•

Courier bold indicates literal commands that you enter in a
syntactical statement. However, braces “{ }” in Courier bold are
not literal and square brackets “[ ]” in Courier bold are literal
only in the case of bus specifications, such as bus [7:0].
rpt_del_net=
Courier bold also indicates commands that you select from a
menu or buttons that you click in dialog boxes.
File → Open
Click OK

•

Italic font denotes the following items.
•

Variables in a syntax statement for which you must supply
values
edif2ngd design_name

•

References to other manuals
See the Development System Reference Guide for more
information.
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•

Emphasis in text
If a wire is drawn so that it overlaps the pin of a symbol, the
two nets are not connected.

•

Square brackets “[ ]” indicate an optional entry or parameter.
However, in bus specifications, such as bus [7:0], they are
required.
edif2ngd [option_name] design_name

•

Braces “{ }” enclose a list of items from which you must choose
one or more.
lowpwr ={on|off}

•

A vertical bar “|” separates items in a list of choices.
lowpwr ={on|off}

•

A vertical ellipsis indicates repetitive material that has been
omitted.
IOB #1: Name = QOUT’
IOB #2: Name = CLKIN’
.
.
.

•

A horizontal ellipsis “. . .” indicates that an item can be repeated
one or more times.
allow block block_name loc1 loc2 ... locn;

Online Document
The following conventions are used for online documents.
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•

Red-underlined text indicates an interbook link, which is a crossreference to another book. Click the red-underlined text to open
the specified cross-reference.

•

Blue-underlined text indicates an intrabook link, which is a crossreference within a book. Click the blue-underlined text to open
the specified cross-reference.
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Chapter 1

Introduction
This chapter introduces the PROM File Formatter. The chapter
contains the following sections.
•

“The PROM File Formatter”

•

“What Is a Xilinx PROM File?”

•

“PROM Description Area Display”

•

“PROM File Formatter Files”

•

“Implementing Your Applications”

•

“Configuration Setups”

•

“XILINX PROM Part Names”

The PROM File Formatter
The PROM File Formatter provides a graphical user interface that
allows you to format BIT files into a PROM file compatible with
Xilinx and third-party PROM programmers. It is also used to
concatenate multiple bitstreams into a single PROM file for daisy
chain applications. This program also enables you to take advantage
of the Xilinx FPGA reconfiguration capability, as you can store
several applications in the same PROM file.
PROM files are also compatible with the Xilinx Hardware Debugger
software. You can use the Hardware Debugger to download a PROM
file to a single FPGA or to a daisy chain of FPGA devices.
The PROM File Formatter performs the same function as the
PROMGen program, which can be executed from the UNIX ™ or PC
command line. Refer to the Development System Reference Guide for
details about PROMGen.
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BIT

PRM
Memory Map

EXO
PROM File

PROM File Formatter

MCS
PROM File

TEK
PROM File

PDR
PROM Description

HEX

Device Configuration
X7558

Figure 1-1 PROM File Formatter Data Flow

What Is a Xilinx PROM File?
A Xilinx PROM file consists of one or more data streams. In this
context, a data stream represents all the configuration data required
to implement a given application. Each data stream contains one or
more BIT files and once saved, will have a separate preamble and
length count. The “Configuration Data Streams” figure illustrates the
structure of a PROM file.
The PROM file can be formatted in one of three industry standard
formats: Intel MCS-86®, Tektronix TEKHEX, and Motorola
EXORmacs.
Note: You can also format BIT files into a HEX format file. This file
type is not considered a PROM file since you cannot use it to program
PROM devices. A HEX format file is ordinarily used as input to userdefined programs for microprocessor downloads.
You can store PROM files in PROM devices or on your computer. In
turn, you can use the files to program your FPGA devices either from
a PROM device on your board or from your computer using a serial
or parallel cable. Refer to the Hardware Debugger Guide for more
information.
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Figure 1-2 Configuration Data Streams

PROM Description Area Display
The PROM description area in the PROM File Formatter window
represents the structure of your PROM file. It consists of one or more
data streams. A data stream is a collection of one or more
concatenated BIT files used to implement a single user application.
•

A data stream consisting of one BIT file contains data to configure
a single device.

•

A data stream consisting of more than one BIT file contains data
to configure a group of devices connected in daisy chain fashion.
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The PROM description area display shows BIT files in the order they
will be loaded into the devices on the chain. The top BIT file is loaded
into the first device, and the bottom BIT file is loaded into the last
device.
Before programming a daisy chain of FPGA devices, you must first
concatenate the BIT files together. Each BIT file corresponds to an
FPGA in the daisy chain.
The “Configuration Data Streams” figure depicts the structure of a
typical PROM file designed to configure a single daisy chain of
devices in master mode. Data Stream #1 configures a daisy chain of
two devices. Data Stream #2 reconfigures the same daisy chain to
perform a different function.

PROM File Formatter Files
This section describes the PROM File Formatter input and output
files.

Input Files
You can input one or more BIT files into the PROM File Formatter. A
BIT file contains configuration information for a single FPGA device.

Output Files
The PROM File Formatter generates the following files as outputs:
•

PROM files—The file or files containing the PROM configuration
information. Depending on the PROM file format your PROM
programmer uses, you can output a TEK, MCS, or EXO file. If
you are using a microprocessor to configure your devices, you
can output a HEX file.
If the data in the PROM File Formatter is going to be split into
multiple PROMs, there will be a PROM file corresponding to
each PROM.

•

1-4

PDR file—A PROM description file. The file is an ASCII report
file listing all the data streams and BIT files used to construct the
PROM file, as well as the load direction and PROM file splitting
information. A single PDR file describes all of the data in the
PROM File Formatter. The PDR file has the same name as the
PROM file and a .pdr extension.
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The following is a sample PDR report file for a single data stream
written in MCS-86 format. The Devices line indicates the data
was split into three serial configuration PROMS.
# Created 1999/02/21 11:00:32
BeginProm
Type
Serial
Format MCS-86
Info MaxAddress 0x00014642
Devices Auto XC17256D XC17256D XC17256D
BeginChain
StartAddress
0x00000000
Direction
UP
Info EndAddress 0x00014642
Info Size
0x00014643
File “/design/fpga1/fpga1.bit”
EndChain
EndProm

•

PRM file—An ASCII file containing a memory map of the output
PROM file. If the data in the PROM File Formatter is split into
multiple PROM files, there will be a PRM file corresponding to
each PROM file.
The following is a sample PRM file.
PROM /design/fpga1/fpga100.prm map: Fri Feb 21
11:00:50 1999
Format
Size
PROM start
PROM end
Addr1
0000:0000

Mcs86
32K
0000:0000
0000:7fff

PROM File Formatter Guide

Addr2 File(s)
0000:7fff /design/fpga1/fpga1.bit
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Bit Swapping in PROM Files
The PROM File Formatter produces a PROM file in which the bits
within a byte are swapped compared to the bits in the input BIT file.
Bit swapping (also called “bit mirroring”) reverses the bits within
each byte, as shown in the following figure.

Original Data

Data in PROM File or HEX File

8
1000

A
1010

0101
5

0001
1

X8074
Figure 1-3 Bit Swapping
In a bitstream contained in a BIT file, the Least Significant Bit (LSB) is
always on the left side of a byte. But when a PROM programmer or a
microprocessor reads a data byte, it identifies the LSB on the right
side of the byte. In order for the PROM programmer or
microprocessor to read the bitstream correctly, the bits in each byte
must first be swapped so they are read in the correct order.
The bits are swapped for all of the PROM formats: MCS, EXO, and
TEK. For a HEX file output, bit swapping is on by default, but it can
be turned off by deselecting a Swap Bits option that is available only
for HEX file format.
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Implementing Your Applications
You can use the PROM File Formatter to generate a PROM file
containing data to configure a single FPGA device or a PROM file to
configure one or more groups of FPGA devices. You can also store
multiple data streams in the same PROM file and use these data
streams to reconfigure a device or daisy chain for different
applications.
The following table summarizes the various ways to structure a
PROM file.
Table 1-1
Number of
Applications

Configuration Data Stream Combinations

Number of FPGA
Devices to Configure

Single Application

Single device

Number of Data Streams and BIT
Files
One data stream with a single BIT file.

Daisy chain of devices One data stream with multiple BIT
files.

Multiple Applications
(Reprogramming)

Multiple daisy chains
of devicesa

Multiple data streams with multiple
BIT files in each data stream. Each data
stream includes configuration data for
a different daisy chain of devices.

Single device

Multiple data streams with a single BIT
file in each data stream.

Daisy chain of devices Multiple data streams with multiple
BIT files in each data stream. Each data
stream programs the group of devices
for a different application.
a. This type of application can be implemented with a byte-wide PROM only. Each data stream will use a
different start-up address in the PROM file.

The following figure depicts the structure of a byte-wide PROM file
loaded in master mode and designed to configure three daisy chains
of devices. Data Stream #1 is for a daisy chain of two devices. Data
Stream #2 is for a second daisy chain of two devices. Data Stream #3
is for a single device.
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Figure 1-4 Configuration Data Streams for Multiple Daisy
Chains
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Single Application PROM Files
There are three different types of configuration data streams.
•

Single Device
To implement an application for a single device, use a data
stream containing a single BIT file. Data Stream #3 in the “Configuration Data Streams for Multiple Daisy Chains” figure shows a
configuration data stream for a single device.

•

One group of daisy-chained devices
To implement an application for a group of FPGA devices
connected together in a daisy chain, use a single data stream
containing multiple BIT files, that is, one BIT file for each device
in the daisy chain. Data Stream #2 in the “Configuration Data
Streams for Multiple Daisy Chains” figure shows a configuration
data stream for a single daisy chain of devices.

•

Several groups of daisy-chained devices
To implement an application for several groups of daisy chained
devices, you must build one data stream per daisy chain. The
“Configuration Data Streams for Multiple Daisy Chains” figure is
an example of a PROM file for multiple daisy chains of devices.
This type of implementation is valid for byte-wide PROMs,
which can be set for different start-up addresses or for creating a
bitstream for microprocessor download.

Multiple Application PROM Files
The Xilinx SRAM FPGA technology allows you to design multiple
applications for a single device or a daisy chain of devices. Each data
stream in the PROM description area represents a different
configuration or application for the same device or daisy chain of
devices.
To implement several applications for a single device, build a PROM
file made of several data streams, with each data stream containing a
single BIT file. To implement several applications for a group of daisy
chained devices, use several data streams containing multiple BIT
files. Each data stream programs the group of devices for a different
application.
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Note: The number of BIT files within each data stream must be the
same.
Refer to the “Configuration Data Streams for Multiple Daisy Chains”
figure for an example of a PROM file designed for multiple
applications. In this figure, Data Stream #1 configures the daisy chain
of devices with the “Slow” application. Data Stream #2 configures the
same daisy chain with the “Fast” application. You can easily switch to
the next application by reprogramming the FPGA from a PROM file
formatted for multiple applications or from a microprocessor.

Configuration Setups
For information on setups for configuring FPGA devices and daisy
chains for a single application, refer to The Programmable Logic Data
Book. For information on setups to support multiple applications, see
the “Multiple Configuration Setups” appendix.

XILINX PROM Part Names
The part name for a Xilinx serial configuration PROM indicates the
PROM’s size and type. The fields in the part name are described in
the following figure.

XC17128EL
Xilinx Prefix
(Always XC)
Indicates this is a PROM Device
(Always 17)
PROM Size
(Approximate Kilobits)
Number
18
36
65
128
256
512
01

=
=
=
=
=
=
=
=

Configuration Bits
18,144
36,288
65,536
131,072
262,144
524,288
1,048,576

PROM Family
Letter(s)
D
E
L
EL

=
=
=
=
=

Family
Standard 5 Volt PROM
5 Volt PROM, smaller process
3 Volt version of D Type
3 Volt version of E Type

X8073

Figure 1-5 PROM Device Names
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Chapter 2

Getting Started
This chapter explains how to invoke and exit the PROM File
Formatter. It describes the PROM File Formatter window and how to
use the PROM File Formatter interface. In addition, it outlines the
features of the online help tool.
The chapter contains the following sections.
•

“Starting the PROM File Formatter”

•

“Exiting the PROM File Formatter”

•

“Using the PROM File Formatter Interface”

Note: Menus, dialog boxes, and parts of the application window are
documented as they appear on a UNIX workstation. Differences
between the PC and workstation applications are documented if
there is a difference in operation between the two platforms.
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Starting the PROM File Formatter
The PROM File Formatter can be started in the following ways.
•

For Foundation, click the Device Programming phase button
within the Project Manager.

When the Select Program dialog box displays, select PROM File
Formatter and click OK.
•

For Alliance, start the PROM File Formatter from within the
Xilinx Design Manager by clicking the PROM File Formatter
button (shown following) in the Design Manager toolbox.

•

If you installed the PROM File Formatter as a stand-alone tool on
a PC, click the PROM File Formatter icon (shown in the previous
figure) on the Windows desktop or select the applicable entry
accessed from the Windows 95® or Windows NT® Start button.

•

To start the PROM File Formatter from the UNIX or DOS
command prompt, enter the following command:
promfmtr [design_name{.bit|.pdr}]
The PROM File Formatter opens in the following way:
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•

If you enter the command line without specifying a
design_name, the PROM File Formatter opens displaying a
new PROM file composed of a single empty data stream. The
properties for the PROM file are the default properties.

•

If you enter a design_name.bit, where design_name.bit is
an existing BIT file, the PROM File Formatter opens
displaying a new PROM file composed of a single data
stream containing the BIT file.
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The file description area (the area on the right side of the
window) displays the directory containing the BIT file. The
properties for the PROM file are the default properties.
•

If you enter a design_name.pdr, where design_name.pdr is
an existing PROM description (PDR) file, the PROM File
Formatter opens displaying the PROM file described by the
PDR file. The file description area (the area on the right side
of the window) displays the directory containing the PDR
file. The properties for the PROM file are the properties set
the last time the file was saved.

•

If you enter a design_name without an extension, the PROM
File Formatter looks for the file design_name.pdr to open.

Exiting the PROM File Formatter
To exit the PROM File Formatter, select File → Exit.
If you have made any changes to the PROM file, a dialog box asks
you if you want to save these changes. Click Yes to save these
changes.

Using the PROM File Formatter Interface
The PROM File Formatter consists of the PROM File main window,
dialog boxes and online Help. Each of these elements are detailed in
the following sections.

PROM File Formatter Window
The PROM File Formatter window, shown in the following figure, is
displayed when you invoke the PROM File Formatter. By default, the
window displays a PROM description area, a file selection area, a
menu bar, a toolbar, and a status bar. You can hide the toolbar and the
status bar by toggling the Toolbar or Status Bar entries from the View
menu.

PROM File Formatter Guide

2-3

PROM File Formatter Guide

Figure 2-1 PROM File Formatter Window Areas

PROM Description Area
The PROM description area, shown in the preceding figure, is the
area in which you assemble the data streams in the PROM file. In this
area, you define one or more BIT files for a PROM file.
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The PROM description area display is hierarchical. You can view the
data streams alone or along with the BIT files they contain. A plus
sign (+) before a data stream indicates that the BIT files in the data
stream are not displayed. A minus sign (–) indicates that the BIT files
are displayed. Select the plus sign or minus sign to toggle the display
between the two states. You can also toggle states by double-clicking
the data stream.
The contents of the PROM description area depend on how you start
the PROM File Formatter. It may include an empty data stream, a
data stream consisting of a single BIT file, or the data streams
produced by a previous PROM File Formatter session. When you add
files to the data stream, the order in which the files are displayed
indicates how they will be loaded into the devices on the chain. The
top BIT file is loaded into the first device, and the bottom BIT file is
loaded into the last device.

File Selection Area
The file selection area is used to locate and select the BIT files that the
PROM file will contain. It contains a hierarchical view of drives,
directories, and BIT files. If your computer is networked, you can also
view the BIT files in networked drives. After locating the BIT files for
your PROM file, you move the names of these BIT files into the
PROM description area.
A plus sign (+) before a directory name indicates that the hierarchy of
that directory has not been expanded in the display. A minus sign (–)
indicates that the directory’s hierarchy has been expanded. Select the
plus sign or minus sign to toggle the display between the two states.
You can also toggle states by double-clicking the name of the
directory.

Menu Bar
The menu bar is located at the top of the PROM File Formatter
window. It includes the File, Edit, View, and Help menus. You can
select menus and menu items with the mouse. You can also select
menu commands by typing the letter underlined in the menu name
while pressing the Alt key, then typing the letter underlined in the
menu command. Refer to the “Menu Command Reference” chapter
for information on the menu commands.

PROM File Formatter Guide
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Toolbar
The toolbar is located at the top of the screen below the menu bar. It
displays several buttons, which you can use to specify commands
directly. The toolbar offers an alternative to the menu commands. The
toolbar buttons are described in the following table.
Button

Name

Function

New

Clears data from the PROM
description area, allowing you to
build a new PROM file.

Open

Allows you to open an existing PDR
file.

Save

Allows you to save the current data.

Split PROM Displays the Split PROM Wizard,
which targets a PROM file to multiple
PROM devices.
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Properties

Allows you to set properties for the
PROM file currently displayed in the
PROM File Formatter window.

Undo

Reverses the last action performed.

Redo

Redoes the last action that was
undone.

Cut

Removes selected items from the
PROM description area and temporarily stores them in the clipboard.
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Button

Name

Function

Copy

Copies selected items from the PROM
description area and temporarily
stores them in the clipboard.

Paste

Inserts the clipboard contents into the
PROM description area.

Move Up

Moves the item selected in the PROM
description area closer to the start of
the PROM.

Move Down Moves the item selected in the PROM
description area closer to the end of
the PROM.

PROM File Formatter Guide

Add BIT
File

Adds a selected BIT file to the data
stream currently selected in the
PROM description area.

Add Data
Stream

Adds a new data stream to the PROM
description area.

Open
Design
Directory

Returns the display in the file
selection area to the display
appearing when the PROM File
Formatter was started or when you
last opened a PDR file within the
PROM File Formatter.
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Button

Name

Function

About

Displays information about the
version number of the PROM File
Formatter.

Help

Invokes context-sensitive Help. When
you click this button, the cursor
changes into a large question mark
with an arrow. You can then select an
object, such as a menu command or a
toolbar button, and receive help for
that object.

To get a short description of a toolbar button, place the mouse pointer
over the button. After about two seconds, a small pop-up text box
appears giving more information about that button. This utility,
called Tool Tips, displays the name of the button function, while the
status bar also displays the information.
On a PC, the toolbar can be arranged in a variety of ways. The toolbar
can either be docked (that is, attached to the PROM File Formatter
window) or floating (that is, contained in its own window).
You can arrange the toolbar in these ways:

2-8

•

To move the toolbar, point to a spot between toolbar buttons (or
to the title bar, if the toolbar is floating), then drag and drop the
toolbar to the desired location. If you drop the toolbar near an
edge of the PROM File Formatter window, it will be docked on
that edge. If you drag the toolbar away from the window edge, it
will float instead of being docked.

•

To toggle between a floating toolbar and a docked toolbar,
double-click a spot between toolbar buttons (or on the title bar, if
the toolbar is floating).

•

To prevent the toolbar from being docked, hold down the Ctrl
key as you move the toolbar.
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Status Bar
The status bar is located at the bottom of the PROM File Formatter
window. The left side of the status bar provides command and
processing information (for example, Ready or Saving PROM
File...), as well as additional help information about the toolbar
buttons. The right side of the status bar shows the PROM file format,
the PROM type (serial or byte wide), the PROM device, and the
percentage of the device that is being used.

Using Dialog Boxes
Many menu commands display dialog boxes in which you can enter
information and set options.

Common Fields
The fields shown in the following table are common to most dialog
boxes.
Table 2-1

Common Dialog Box Fields

Dialog Box Field

Function

OK

Closes the dialog box and implements the intended action
according to the settings in the
dialog box

Cancel

Closes the dialog box without
effecting any action

Help

Displays information on that
particular dialog box

Moving Items Within List Boxes
Many of the dialog boxes feature list boxes. You can select and move
items from one list box to another using either the mouse or the
keyboard, or a combination of these methods.
Use the mouse to select items in list boxes as follows.
•

To move an item to a list box on the right, select it with the left
mouse button. Click the > button. To move an item to a list box
on the left, select it, then click the < button.
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•

To move all items to a list box on the right, click the >> button. To
move all items to a list box on the left, click the << button.

•

To move sequential items, select the first one with the left mouse
button. Hold down the Shift key. Select the last item and release
the Shift key. Click the > or < button to move the selected items
to the right or left list box, respectively.
You can also select the first item; drag the mouse up or down
until all the desired items are highlighted; and then click the > or
< button.

•

To move multiple items in any order, hold down the Ctrl key
while clicking individual items. When you finish selecting,
release the Ctrl key and click the > or < button.

Use the keyboard to select items in list boxes as follows.
•

To move an item in a list box, press the Tab key until the first
item in the list box is highlighted. Press the down arrow key to
select the desired item. Tab to the > or < button to move it to the
right or left list box, respectively. Press Enter.

•

To move all items to a list box on the right, tab to the >> button
and press Enter. To move all items to a list box on the left, tab to
the << button and press Enter.

•

To move consecutive items, tab to the first item in the list box.
Use the down arrow key to highlight the first desired item. Press
and hold the Shift key while using the down arrow key to
select the other items in the sequence. Tab to the > button. Press
Enter.

•

On workstations only: To move multiple items in any order, tab to
the list box and press Shift F8. Use the up and down arrow
keys to navigate within the list box. Press the space bar to select
each item. Tab to the > button. Press the Enter key.

Using Filters with Commands
Many menu commands have dialog boxes that allow you to filter a
list of choices, that is, display a subset of the listed items. These dialog
boxes contain a filter field, Apply buttons, and Clear or Reset buttons.
In filter fields, you can enter a text string consisting of characters and
wildcards. You cannot enter a range of items in filter fields.
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•

Characters can be any alphanumeric characters, text spaces, and
the characters that appear on the top of the number keys on a
keyboard. Alphabetic characters are case-sensitive. Control
characters are not permitted.

•

A wildcard can be an asterisk (*), which can represent any
number of characters, or a question mark (?), which represents a
single character.

The software does not strictly match patterns; it matches entire text
strings. It does not find a string if it is embedded in a larger string
unless you use wildcards. For example, it does not find $1N36 if it is
embedded in ABC$1N36XYZ. However, if you searched for *$1N36*,
it would find that string in ABC$1N36XYZ.
To use the Filter dialog boxes, follow these steps.
1.

Specify the pattern to include in your list by typing the characters.

2.

Include one or more wildcards (*) to do a global search on the
specified string.
Precede the character string with a wildcard to retrieve all signal
names that end with the string of specified characters.
Append the wildcard to the character string to retrieve all signal
names that start with the specified character string.

3.

Click Apply.
The list displays only the choices that match the selection criteria.

4.

To clear the filter, click Clear or Reset or backspace over the
information specified in the filter text box.

Using the Online Help
Most graphical user interfaces (GUIs) contain context-sensitive help
and a Help menu. You can obtain help on commands and procedures
with the Help menu or by selecting the Help toolbar button. In
addition, the dialog boxes associated with many commands have a
Help button that you can click to obtain context-sensitive help.

Help Menu
Use the following Help menu commands to get help.

PROM File Formatter Guide
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•

The Help Topics command opens Help and lists the online help
topics available for the PROM File Formatter. From the Contents
page, you can jump to command information or step-by-step
instructions for using the PROM File Formatter. Once you open
Help, you can click the Contents button in the Help window
whenever you want to return to the Help contents.

•

The About PROM File Formatter command displays a popup
window that displays the version number of the PROM File
Formatter software and a copyright notice.

Toolbar Help Button
You can obtain context-sensitive help from the toolbar as follows.
1.

Click the Help button in the toolbar.

The cursor changes to a question mark with an arrow.
2.

Click once with the left mouse button on the menu item or
toolbar button for which you want help.
The PROM File Formatter displays help for the selected
command or option.

Note: You can also press Shift F1 to obtain context-sensitive help.

F1 Key
Pressing the F1 key on a dialog box displays help on that dialog box.
Pressing the F1 key is the same as selecting Help Topics from the
Help menu, if no dialog boxes are displayed.

Help Button in Dialog Boxes
Many of the dialog boxes in the PROM File Formatter have a Help
button that you can click to obtain help for the dialog box with which
you are working. You can also press Alt H on your keyboard while
positioned over the dialog box to obtain help.
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Using the PROM File Formatter
This chapter describes the functions that you can perform with the
PROM File Formatter.
The PROM File Formatter window areas referred to in this chapter
are described in the “PROM File Formatter Window” section of the
“Getting Started” chapter.
The chapter contains the following sections.
•

“Creating a New PROM File”

•

“Opening an Existing PROM File”

•

“Building a PROM File”

•

“Editing a PROM File”

•

“Setting the PROM Properties”

•

“Saving a PROM File”

•

“Splitting a PROM File”

Creating a New PROM File
To create a new PROM file, select File → New.
The PROM description area displays a single empty data stream.
The default name of the new PROM file will be untitled.format, where
format is the default format (.tek, .mcs, .exo, or .hex) set for the PROM
File Formatter. The new PROM description file will be named
untitled.pdr and the new memory map file will be named
untitled.prm.
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Opening an Existing PROM File
To open an existing PROM file:
1.

Select File → Open to display the Open dialog box, as shown in
the following figure.

Figure 3-1 Open Dialog Box
2.

Complete this dialog box and click OK to open the desired PROM
description (PDR) file.
This is a standard file selection dialog box. For a description of
the fields in the dialog box, refer to the documentation and online
help for the applicable Windows-based system.

Building a PROM File
You build a PROM file by adding BIT files and data streams to the
PROM description area in the PROM File Formatter window. A data
stream can contain one or more BIT files. A data stream that contains
multiple files is referred to as a daisy chain.
To build the PROM file, you add BIT files to the data stream in the
PROM description area. You can also create additional data streams,
and add BIT files to them.
The size of a data stream is indicated as part of the Data Stream entry
in the PROM description area. After you add a file to a data stream,
the data stream size is updated to include the data in the added file.
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Adding a BIT File to a Data Stream
1.

In the hierarchical display in the file selection area, select the BIT
file you want to add to the data stream.
You can only select one BIT file at a time.

2.

In the PROM description area, select the entry below which you
will add the BIT file.
To add the BIT file to the end of a data stream, select the End
entry for the data stream.

3.

Select Edit → Add Bit File. The BIT file appears in the PROM
description area. The Xilinx device for which the BIT file was
created is included in this BIT file entry.

Note: You can also add a BIT file by selecting the PROM description
area entry below which you will add the BIT file, then doubleclicking the BIT file you want to add.
On a PC only, you can add a BIT file to a data stream by dragging the
file from the file selection area into the PROM description area, then
dropping the file into the desired position in the data stream. As you
move the file into the PROM description area, an arrow to the left of
the display indicates the position at which the BIT file will be placed.

Adding a New Data Stream
To add a new data stream, select Edit → Add Data Stream.
A new data stream is added to the end of the PROM file, and this data
stream appears in the PROM description area. You can move BIT files
into this new data stream.
The new data stream is used to reconfigure a single device or daisy
chain of devices for a new function.
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Editing a PROM File
After building a PROM file, you can edit the file by moving BIT files
to change the sequence of files in a data stream. You can also move
data streams to change their sequence or delete BIT files and data
streams.

Moving BIT Files
To move a BIT file to a different location in the PROM file:
1.

In the hierarchical display in the PROM description area, select
the BIT file you want to move.

2.

Select Edit → Cut.

3.

In the PROM description area, select the entry above which you
will add the BIT file.

4.

Select Edit → Paste.
You can also move BIT files using the following menu
commands:
•

Move Up (Edit Menu)

•

Move Down (Edit Menu)

These commands are described in the “Menu Command Reference”
chapter.
On a PC only, you can move a BIT file by dragging it from its current
position in the PROM description area and dropping it into the
desired position. As you move the BIT file within the PROM
description area, an arrow to the left of the display indicates the
position at which the BIT file will be placed.

Moving Data Streams
To move data streams:
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1.

In the hierarchical display in the PROM description area, select
the data stream you want to move.

2.

Select Edit → Cut.

3.

In the PROM description area, select the data stream above which
you will add the cut data stream.
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To add the data stream to the end of the PROM Description area
display, select the End PROM entry.
4.

Select Edit → Paste.

You can also move data streams using the following menu
commands.
•

Move Up (Edit Menu)

•

Move Down (Edit Menu)

These commands are described in the “Menu Command Reference”
chapter.
On a PC only, you can move a data stream by dragging it from its
current position in the PROM description area and dropping the data
stream into the desired position. As you move the data stream within
the PROM description area, an arrow to the left of the display
indicates the position at which the data stream will be placed.

Duplicating BIT Files and Data Streams
You can duplicate BIT files or data streams in the PROM description
area by using either of these sequences of menu commands.
•

Copy (Edit Menu) and Paste (Edit Menu)

•

Cut (Edit Menu) and Paste (Edit Menu)

These commands are described in the “Menu Command Reference”
chapter.

Deleting BIT Files or Data Streams
To delete a BIT file or a data stream, select the entry you want to
delete from the PROM description area and perform any of these
actions.
•

Press the Delete key

•

Select Edit → Cut

•

Click the Cut button (shown following)
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Setting the PROM Properties
To set properties for the PROM file you create:
1.

Select File → PROM Properties to open the PROM Properties
dialog box, as shown in the following figure.

Figure 3-2 PROM Properties Dialog Box
2.

In the PROM File Format field, select the format compatible with
your PROM formatter or select HEX for a file to be used in
microprocessor downloads.
Some PROM formats support larger file sizes than others. The
“PROM Formats and Sizes” table of the “Menu Command
Reference” chapter shows the capacity of each of the PROM
formats supported by the PROM File Formatter.

3.
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If you selected HEX in the PROM File Format field, perform either
one of the following:
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4.

•

If you want to disable bit swapping, deselect the Swap Bits
field (not shown in the “PROM Properties Dialog Box”
figure). Bit swapping is described in the “Bit Swapping in
PROM Files” section of the “Introduction” chapter.

•

Click OK to close the PROM Properties dialog box.

In the Type field, select Serial or Byte Wide PROM.
Xilinx PROMs are serial devices.

5.

In the PROM File field, select Single PROM or Split PROM.
To determine whether the data must be split into multiple
PROMs, you can check the Percent Used field on the right side of
the dialog box. If the Percent Used is above 100% (indicating the
data is larger than the largest supported PROM), you may have
to split the data into multiple PROMs.

6.

7.

If you selected Single PROM in the PROM File field, perform the
following in the PROM Device (size) area:
•

If you want the PROM File formatter to automatically select
the smallest single PROM into which your data will fit, select
the Automatic Selection box.

•

If you want to select the PROM to use, deselect the
Automatic Selection box and select a PROM from the PROM
Device (size) selection box.

If you selected Split PROM in the PROM File field, so that the PROM
Device (size) area appears as shown in the following figure,
perform the following in the PROM Device (size) area.

Figure 3-3 PROM Devices (Size) Area for Split PROM
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8.

•

If you want the PROM File formatter to automatically select
the smallest number of PROMs into which your data will fit,
do nothing.

•

If you want to select the PROMs to use, select Split PROM
Wizard. When the Split PROM Wizard Appears, follow the
instructions in the “Splitting a PROM File” section to specify
the desired PROMs.

If you selected Byte Wide in the Type field, click the Data Streams tab
of the dialog box.
For a byte wide PROM, the Data Streams tab appears as shown in
the following figure.

Figure 3-4 Data Streams Tab (Serial PROM)
If desired, modify the data streams by selecting a stream in the
list at the top of the dialog box, modifying the Starting Address
or Loading Direction in the fields below the list, and clicking
Apply.
Choose the Up direction if you want to store the data starting at a
low address and load it in the upward direction.
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Choose the Down direction if you want to store the data starting
at a high address and load it in the downward direction.
9.

Click OK to close the PROM Properties dialog box.

Saving a PROM File
To save a PROM file:
1.

Select File → Save.
If this is the first time you are saving the PROM file, the Save As
dialog box appears, as shown in the following figure.

Figure 3-5 Save As Dialog Box (PROM File)
2.

Complete this dialog box and click OK to save the PROM files and
the PROM description file.
This is a standard file selection dialog box. For a description of
the fields in the dialog box, refer to the documentation and online
help for the applicable Windows-based system.

If the properties currently set in the PROM File Formatter specify a
PROM type smaller than necessary to hold the PROM data, the
PROM File Formatter posts the dialog box shown in the “Invalid
PROM Size Dialog Box” figure. The dialog box prompts you to
perform one of these actions.
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•

Select a larger PROM

•

Split the data across multiple PROMs using the Split PROM
Wizard

•

Save just the PROM description, without saving a PROM file

Figure 3-6 Invalid PROM Size Dialog Box
If you have chosen a PROM format that does not support the size of
your PROM file, the PROM File Formatter posts the dialog box
shown in the “Invalid Stream Layout Dialog Box” figure. The dialog
box prompts you to perform one of these actions.
•

Edit the properties to change the PROM format

•

Save the PROM description without saving a PROM file

Figure 3-7 Invalid Stream Layout Dialog Box
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In some cases, you may want to save only the PROM description file,
without saving the related PROM files. For example, you may want
to save just the PROM description file if the data in the PROM File
Formatter is incomplete, and you want to ensure that no PROM files
are saved, because they might be confused with completed PROM
files. To save just the PROM description file, select File → Save
Description instead of File → Save.

Splitting a PROM File
You can retarget existing MCS, EXO, or TEK files to multiple serial or
parallel PROM devices by splitting your PROM file into smaller files.
Serial PROMs will be split into multiple serial PROMs, and byte wide
PROMs will be split into multiple byte wide PROMs.
Note: You can only retarget MCS, TEK, and EXO file formats. You
cannot retarget a HEX file because you cannot use this format to
program a PROM device. Use HEX files for user-defined processes
(for example, a microprocessor download) or programs.
The Split PROM Wizard retargets a PROM file to multiple PROM
devices. The Split PROM Wizard always acts on the PROM file
currently displayed in the PROM File Formatter.
To split a PROM file, use the following steps.
1.

Activate the Split PROM Wizard in any of the following ways.
•

Select File → Split PROM.
If you are setting properties for a PROM file, specify Split
PROM in the Format tab of the PROM Properties dialog box. A
Split PROM Wizard button will appear in the dialog box;
select the button.

•

If you try to save a PROM file into a PROM device that is too
small, the Invalid PROM Size dialog box appears. Select the
Split PROM option from this dialog box.

The PROM File Formatter displays the Split PROM Wizard
dialog box, shown in the following figure.
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Figure 3-8 Split PROM Wizard Dialog Box
2.

Select one of the options displayed in the dialog box (Automatic,
or Custom), then click Next. Depending on the option you select,
proceed to one of the following sections to finish splitting the
PROM file.
•

“Automatic Selection” section

•

“Custom Selection” section

Automatic Selection
The Automatic selection option of the Split PROM Wizard selects the
minimum number of PROMs required to contain the data. If you
selected Automatic in the Split PROM Wizard dialog box, the dialog
box shown in the following figure appears.
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Figure 3-9

Split PROM Wizard—Automatic

The information in this dialog box is read-only; it indicates the
devices into which the PROM File Formatter divided the existing
PROM file and the size of each device.
Click Finish to complete the PROM Wizard.

Custom Selection
The Custom selection option of the Split PROM Wizard allows you to
select the PROMs into which you will target your data. If you selected
Custom in the Split PROM Wizard dialog box, the dialog box shown
in the following figure appears.
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Figure 3-10

Split PROM Wizard—Custom

The three fields at the top of the dialog box provide information on
the status of the current PROM file allocation.
•

Bytes Required indicates the size of the PROM file you are
splitting or total number of bytes to be allocated.

•

Bytes Available indicates the number of bytes available in the set
of devices you have chosen.

•

Bytes Remaining indicates the number of bytes that still need to
be allocated.

To build up the list of devices in the Devices Used list, perform the
following operations.
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•

To add the first device to the Devices Used list, select the device
in the Available Devices list and click >, or double-click the
device in the Available Devices list.

•

To add an additional device to the list, select the entry in the
Devices Used list under which you want to enter the new device.
Then perform either of the following:
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•

In the Available Devices list, select the device you want to
add and click >.

•

In the Available Devices list, double-click the device you
want to add to the list.

The selected PROM device appears in the Devices Used list,
which displays the target PROMs in the order in which the
PROM file is to be split.
•

To change the order of the devices, select a device in the Devices
Used list and click Move Up or Move Down.

•

To delete a device from the list, select a device in the Devices
Used list and click Remove.

•

To empty the Devices Used list, click Remove All.

When you have finished building the Devices Used list, click Finish
to split the PROM file using the devices you just specified in the listed
order. The Finish button is grayed out and cannot be used until you
have allocated all the bytes of your PROM file and the Bits Remaining
box reaches 0.
When you click Finish, the PROM File Formatter creates a single PDR
report file, multiple PRM files, and multiple PROM files as you specified in the Split PROM Wizard. The PDR report lists all the data
streams and BIT files used to construct the PROM files as well as the
load direction and PROM file splitting information. Each PRM file
contains a memory map of the data for one PROM.
Each PROM file is assigned a default file name in the form of an
appended 00, 01, ..., 0n suffix to the input file name. For example, if
the original file name is design.mcs and the PROM file is split into
three smaller PROM files, they will be named as follows:
design00.mcs, design01.mcs, and design02.mcs.
The files are written to disk when you perform a Save or Save As
command. The files are saved in the design directory.
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Chapter 4

Menu Command Reference
This chapter lists and describes all the commands available in the main
window of the PROM File Formatter. The commands are listed in
alphabetical order. When applicable, the corresponding toolbar button is
included in the command description.
The chapter contains the following sections.
•

“Menus”

•

“Alphabetical Listing of Commands”

Menus
The PROM File Formatter has four menus, which are described in the
following sections.
•

“File Menu”

•

“Edit Menu”

•

“View Menu”

•

“Help Menu”

PROM File Formatter Guide— 2.1i
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File Menu
The File menu contains commands to create, open, save, split, and set
properties for PROM File Formatter files. Following are the File menu
commands and a brief explanation of each.
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New

Clears the data from the PROM File
Formatter window and creates a new,
empty PROM file.

Open

Displays a dialog box that allows you to
open an existing PROM file.

Save

Saves the current PROM file and PROM
description file.

Save As

Displays a dialog box that allows you to
save the current PROM file and PROM
description file with a file name and a
location you specify.

Save Description

Saves the current PROM description (PDR)
file.

Save Description As

Displays a dialog box that allows you save
the current PROM description (PDR) file
with a file name and a location you specify.

Split PROM

Displays the Split PROM Wizard, which
allows you to split the current PROM file
into multiple files.

PROM Properties

Displays the PROM Properties dialog box,
which allows you to set properties for the
file displayed in the PROM File Formatter
window.

Recent Files

Displays the names of the last four PROM
description files opened in the PROM File
Formatter.

Exit

Exits the PROM File Formatter program.
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Edit Menu
The Edit menu contains commands to build and edit the information in the
PROM description area. The following are the Edit menu commands and a
brief explanation of each.
Undo

Reverses the last action performed.

Redo

Redoes the last action that was undone.

Cut

Removes selected items from the PROM
description area and temporarily stores
them in the clipboard.

Copy

Copies selected items from the PROM
description area and temporarily stores
them in the clipboard.

Paste

Inserts the clipboard contents into the
PROM description area.

Move Up

Moves the item selected in the PROM
description area closer to the start of the
PROM.

Move Down

Moves the item selected in the PROM
description area closer to the end of the
PROM.

Add Data Stream

Adds a new data stream in the PROM
description area.

Add Bit File

Inserts the BIT file selected in the file
selection area into the PROM description
area.

PROM File Formatter Guide
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View Menu
The View menu includes commands to display special screen areas and to
modify the appearance of the information displayed within the PROM File
Formatter window. Following are the View menu commands and a brief
explanation of each.
Toolbar

Toggles the toolbar on or off.

Status Bar

Toggles the status bar on or off.

Show File Paths

Displays the BIT files in the PROM
description area with their full path names.

Collapse All Streams

Collapses the hierarchical display in the
PROM description area, leaving a display
of data streams without BIT files.

Expand All Streams

Expands the hierarchical display in the
PROM description area to show all data
streams and all BIT files.

Design Directory

Returns the display in the file selection area
to the display appearing when the PROM
File Formatter was started or when you last
opened up a PDR file within the PROM
File Formatter.

Move Splitter

Places the cursor on the splitter bar,
allowing you to change the relative sizes of
the PROM description area and the file
selection area.

Help Menu
The Help menu contains commands that enable you to access online help for
the PROM File Formatter. Following are the Help menu commands and a
brief explanation of each.
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Help Topics

Lists online help topics.

About PROM File Formatter

Displays the program version.
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Alphabetical Listing of Commands
The following commands are available in the menus of the PROM File
Fomatter’s graphical user interface.

About PROM File Formatter (Help Menu)
This command displays information about the version number of the PROM
File Formatter.

Add Bit File (Edit Menu)
Adds a BIT file to the display in the PROM description area.
The following toolbar button executes the Add Bit File command.

To add a BIT file using the Add Bit File command, follow these instructions:
1.

In the hierarchical display in the file selection area, select the BIT file
you want to add to the data stream.
You can only select one BIT file at a time.

2.

In the PROM description area, select the entry below which you will
add the BIT file.
To add the BIT file to the end of a data stream, select the End entry for
the data stream.

3.

Select Edit → Add Bit File or select the Add Bit File toolbar
button.
The BIT file appears in the PROM description area. The Xilinx device
for which the BIT file was created is included in this BIT file entry.

Note: You can also add a BIT file by selecting the PROM description area
entry below which you will add the BIT file, then double-clicking the BIT
file you want to add.
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Add Data Stream (Edit Menu)
This command adds an empty data stream to the display in the PROM
description area. The data stream is added before the End PROM entry.
The following toolbar button executes the Add Data Stream command.

Collapse All Streams (View Menu)
This command collapses the hierarchical display in the PROM description
area, leaving a display of data streams without BIT files.

Copy (Edit Menu)
This command copies a selected data stream or BIT file from the PROM
description area and temporarily stores it on the clipboard. The command is
available only if there is a selected file or data stream.
The following toolbar button executes the Copy command.

To copy multiple data streams or BIT files to the clipboard, use the multiple
object selection method described in the “Using Dialog Boxes” section of
the “Getting Started” chapter before you execute the Copy command.
To duplicate data streams or BIT files, you can first copy them, then paste
them back to insert as many copies as needed.
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Cut (Edit Menu)
This command removes a data stream or a BIT file from the PROM
description area and temporarily stores it on the clipboard. The command is
available only if there is a selected file or data stream.
The following toolbar button executes the Cut command.

To cut multiple data streams or BIT files, use the multiple object selection
method described in the “Using Dialog Boxes” section of the “Getting
Started” chapter before you execute the Cut command.
To duplicate data streams or BIT files, you can first copy them, then paste
them back to insert as many copies as needed.

Design Directory (View Menu)
Changes the contents of the file selection area so the design directory (and
the BIT files in that directory) are displayed.
The following toolbar button executes the Design Directory command.

When you start the PROM File Formatter, the design directory has an initial
value depending on how you started the program.
•

If the program is started without any options, the design directory will
be the current directory.

•

If the program is started with an option that specifies a BIT file to place
in the PROM file or a PDR file to open, the design directory will be the
directory containing the BIT file or PDR file.

Once the PROM File Formatter is open, the design directory may be changed
by the following operations:
•

Opening up a different PDR file causes the design directory to be set to
the location of the PDR file.

PROM File Formatter Guide
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•

Creating a new PROM description resets the design directory back to
the current directory.

•

Saving the PROM description file using any of the following commands
causes the design directory to have the value of the location of the saved
PDR file.
•

Save As

•

Save Description As

•

Save (for a new PROM description file)

•

Save Description (for a new PROM description file)

Exit (File Menu)
Use this command to exit from the PROM File Formatter program. If you are
in the process of creating a PROM file, the program prompts you to save the
current data.

Expand All Streams (View Menu)
Expands the hierarchical display in the PROM description area to show all
data streams and all BIT files.

Help Topics (Help Menu)
This command displays a dialog box that lists the contents of the Help
facility.

Move Down (Edit Menu)
This command moves the entry currently highlighted in the PROM description area down (that is, closer to the end of the PROM). The highlighted
entry may be either a data stream or a BIT file.
The following toolbar button executes the Move Down command.
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Move Splitter (View Menu)
This command moves the cursor to the splitter bar, allowing you to change
the relative sizes of the PROM description area and the file selection area.

Move Up (Edit Menu)
This command moves the entry currently highlighted in the PROM
description area up (that is, closer to the beginning of the PROM). The
highlighted entry may be either a data stream or a BIT file.
The following toolbar button executes the Move Up command.

New (File Menu)
This command clears the data currently loaded in the PROM File Formatter
window and creates a new, empty PROM file, PROM description file, and
memory map file. The new PROM file will be named untitled.format, where
format is the default format (.tek, .mcs, .exo, or .hex) set for the PROM File
Formatter.
The new PROM description file will be named untitled.pdr and the new
memory map file will be named untitled.prm.
The following toolbar button executes the New command.

Once you have removed the old data from the window, you can start building
a new PROM file. If you click New while you are in the process of creating a
data stream, a warning message asks you if you want to save changes to the
current PROM file before you open a new one.
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Open (File Menu)
This command opens an existing PROM file (stored in PDR format).
The following toolbar button executes the Open command.

When you select this command, the Open dialog box appears, as shown in
the following figure.
Note: The dialog box shown in the figure is the dialog box as it appears on a
PC.

Figure 4-1 Open Dialog Box
This is a standard file selection dialog box. For a description of the fields in
the dialog box, refer to the documentation and online help for the applicable
Windows-based system.
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Paste (Edit Menu)
This command inserts the data stream or BIT file currently in the clipboard
into the PROM description area. If an item is selected in the PROM
description area, and the item is of the same type as the cut or copied item
(that is, both are data streams or both are BIT files), the command pastes
before the selected item.
The following toolbar button executes the Paste command.

To duplicate data streams or BIT files, you can first copy them, then paste
them back to insert as many copies as needed.

PROM Properties (File Menu)
This command opens the PROM Properties dialog box, which lets you set
properties for the PROM file currently displayed in the PROM File
Formatter window.
The following toolbar button executes the PROM Properties command.

The dialog box has three tabs, each of which is described in the following
sections.

Format Tab (PROM Properties Dialog Box)
You set the PROM file format in the Format tab of the PROM Properties
dialog box. The Format tab is shown in the following figure.
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Figure 4-2

PROM Properties Dialog Box—Format

Xilinx recommends that you first decide which PROM type and which
PROM file format you will be using. Some PROM formats support larger
file sizes than others. The following table shows the capacity of each of the
PROM formats supported by the PROM File Formatter.
Table 4-1
Format
TEKHEX
MCS-86
EXORmacs
HEX

PROM Formats and Sizes
Number of Addresses
(Bytes)
65,536

Total Number of Bits
524,288

1,048,576

a

8,388,608

16,777,216

b

134,217,728

No limit

No limit

a.This size applies to the Up loading direction only. The Down loading direction is limited
to 64 K.
b.Files with up to 65,536 addresses are formatted in S19 format. Files with more than
65,536 addresses are formatted in S28 format.
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The Format tab contains the following fields.
•

PROM File Format
Specifies the PROM format compatible with your PROM programmer.
Click the down arrow to view the available formats: TEKHEX, MCS86, EXORmacs, and HEX.
If you choose a format that does not support the size of your PROM file,
you receive a warning when you try to close the PROM Properties
dialog box.

•

Type
By default, the Serial radio button is selected. If you are targeting byte
wide PROMs, click the Byte Wide radio button. Xilinx PROMs are
serial devices.

•

PROM File
Specifies whether the PROM file will be implemented in a single PROM
or will be split into multiple PROMs. A separate PROM file is created
for each PROM.
If you select Split PROM, additional fields appear on this tab of the
dialog box.

•

Save As Defaults
Saves the current settings in the Format tab as the default setting for new
PROM files. These defaults will remain in effect the next time you open
the PROM File Formatter.

•

PROM Device (Size)
The fields in this area vary depending on the selection in the PROM File
field. If Single PROM is selected in the PROM File field, the PROM
Device (Size) area displays as shown in the “PROM Properties Dialog
Box—Format” figure. If Split PROM is selected in the PROM File field,
the PROM Device (Size) area displays as shown in the following figure.

PROM File Formatter Guide

4-13

PROM File Formatter Guide

Figure 4-3

PROM Devices (Size) Area—Split PROM

The area contains the following fields.
•

Automatic Selection (Single PROM only)
If Automatic Selection is enabled, the PROM File Formatter automatically selects the smallest single PROM into which your data
will fit.
If Automatic Selection is disabled, click the down arrow to view
available devices and their sizes. The list displays the sizes for
either serial or byte wide PROMs depending on the Type selected.
From the list, you can select the desired PROM.

•

PROM Device (Size) box
For a single PROM, this box specifies the PROM to use and its size.
The size is expressed in bits for a serial PROM and in bytes for a
byte wide PROM.
This is a read-only field if Automatic Selection is enabled and a
selection box if Automatic Selection is disabled. If this field
specifies a PROM size smaller than your data size, you receive a
warning when you try to close the PROM Properties dialog box.
For a split PROM, the PROM Device (Size) box indicates the
PROMs to use and the size of each PROM. The size is expressed in
bits for a serial PROM and in bytes for a byte wide PROM. By
default, the largest available PROM device is used for the first N-1
devices, and the smallest device that will hold the remainder of the
data is chosen for the last device. You can click the Split PROM
Wizard button to change the PROMs shown in this box.
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•

Percent Used (Single PROM only)
Indicates the percent of the PROM used by the data currently in the
PROM description area.

•

Split PROM Wizard button (Split PROM only)
When selected, this button opens the Split PROM Wizard dialog
box, which allows you to specify how the data will be split into
multiple PROMs. The Split PROM Wizard is described in the “Split
PROM (File Menu)” section.

•

Swap Bits
This option (which is not shown in the “PROM Properties Dialog Box—
Format” figure) only appears if HEX is selected in the PROM File
Format field. If Swap Bits is selected, bits in the HEX file will be
swapped compared to bits in the input BIT files. Bit swapping is
described in the “Bit Swapping in PROM Files” section of the
“Introduction” chapter.

•

OK button
Click OK to save the settings in the PROM Properties dialog box.
If the selected PROM device is smaller than the data size or if the
specified PROM file format is inadequate for the data size, you receive a
warning when you try to close the PROM Properties dialog box. You
can save these properties even though you receive a warning, but you
will be warned again if you try to save the PROM file with these
properties.

Data Streams Tab (PROM Properties Dialog Box)
The Data Streams tab indicates the loading direction, start address, and end
address of each data stream stored in the PROM. If you are targeting the byte
wide PROM type, you can also use this tab to change the starting address
and loading direction of the data streams.
The fields in this tab vary depending on the PROM type (serial or byte wide).
The following figures illustrate the two versions of the tab.
•

The Data Streams tab for serial PROMs is shown in the following
figure.

•

The Data Streams tab for byte-wide PROMs is shown in the “PROM
Properties Dialog Box—Data Streams (Byte Wide PROM)” figure.
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Figure 4-5 PROM Properties Dialog Box—Data Streams (Byte
Wide PROM)
The Data Streams tab includes the following fields.
•

Data Stream box
Indicates the loading direction, start address, and end address of all the
data streams in the PROM file.
If you are targeting byte-wide PROMs and you want to change an entry
in the Data Stream box, select the data stream you need to modify. Once
you have highlighted a data stream, the Starting Address and the
Loading Direction fields located below the list box are loaded with the
appropriate information and can be modified.

•

Starting Address and Loading Direction boxes (byte wide only)
Edit the starting address and select the loading direction as needed.
To change the loading direction, perform the following steps.
•
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Choose the Up direction if you want to store the data starting at a
low address and load it in the upward direction.
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•
•

Choose the Down direction if you want to store the data starting at a
high address and load it in the downward direction.

Apply button (byte wide only)
Click this button to update the data stream box with the changes you
have made to a data stream’s Starting Address, Loading Direction, or
both.
After clicking Apply, the Start and End addresses of the current data
stream and those of adjacent data streams are updated to accommodate
the change. If a change forces Data Stream 1 to load below the address
0, an error message will be displayed.

Files Tab (PROM Properties Dialog Box)
The Files tab lets you view the files associated with the data in the PROM
File Formatter. The files are shown in a read-only list. The tab is shown in
the following figure.

Figure 4-6
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Following are the three file types listed in the Files tab.
•

PDR File—An ASCII report file listing all the data streams and BIT
files used to construct the PROM file, as well as the load direction and
PROM file splitting information. The file has the same name as the
PROM file and a .pdr extension.

•

PRM File—An ASCII file containing a memory map of the output
PROM file. If the data in the PROM File Formatter is split into multiple
PROM files, there will be a PRM file corresponding to each PROM file.

•

PROM Files—The file or files containing the PROM configuration
information. Depending on the PROM file format you have chosen, the
PROM files will have either a .tek, .mcs, .exo, or .hex extension.
For split PROMs, there will be one PROM file for each targeted PROM.
The files are named by adding a 00, 01, ..., 0n suffix to the input file
name.
For example, if the original file name is design.mcs and the PROM file
is split into three smaller PROM files, they will be named as follows:
design00.mcs, design01.mcs, and design02.mcs.
Each PROM file will have a matching PRM file.
There is only a single PDR file to describe the data in the PROM File
Formatter, even if the data has been split into multiple PROM files.

Redo (Edit Menu)
This command redoes the last action that was undone.
The following toolbar button executes the Redo command.

Save (File Menu)
The Save command saves all of the files associated with the data in the
PROM File Formatter—the PDR file, the PRM file, and the PROM files. The
files are saved with their current file names and location.
The following toolbar button executes the Save command.
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If you are saving the information in the PROM File Formatter for the first
time, the Save As dialog box appears, as shown in the following figure.
Note: The dialog box shown in the figure is the dialog box as it appears on a
PC.

Figure 4-7 Save As Dialog Box
This is a standard file selection dialog box. For a description of the fields in
the dialog box, refer to the documentation and online help for the applicable
Windows-based system.

Save As (File Menu)
The Save As command saves the PROM File Formatter data to the file names
and directory you specify.
When you select this command, the Save As dialog box appears, as shown in
the preceding figure. This is a standard file selection dialog box. For a
description of the fields in the dialog box, refer to the documentation and
online help for the applicable Windows-based system.
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Save Description (File Menu)
The Save Description command saves the PROM description (PDR) file,
without saving the PROM file or the PRM file. The PDR file is saved with its
current file name and location.
If you are saving the PROM description file for the first time, the Save As
dialog box appears, as shown in the “Save As Dialog Box” figure. This is a
standard file selection dialog box.
For a description of the fields in the dialog box, refer to the documentation
and online help for the applicable Windows-based system.

Save Description As (File Menu)
The Save Description As command saves the PROM description (PDR) file
(without saving the PROM file) to the file name and directory you specify.
When you select this command the Save As dialog box appears, as shown in
the “Save As Dialog Box” figure. This is a standard file selection dialog box.
For a description of the fields in the dialog box, refer to the documentation
and online help for the applicable Windows-based system.

Show File Paths (View Menu)
This command displays the BIT files in the PROM description area with
their full path names.

Split PROM (File Menu)
This command retargets a PROM file to multiple PROM devices. If the
PROM file has already been split, the Split PROM command lets you modify
the way the split is performed.
The following toolbar button executes the Split PROM command.

The procedure for splitting a PROM is described in the “Splitting a PROM
File” section of the “Using the PROM File Formatter” chapter. The Split
PROM Wizard dialog boxes are described below.
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When you select Split PROM, the dialog box shown in the following figure
appears.

Figure 4-8 Split PROM Wizard Dialog Box
The options in this dialog box are listed as follows.
•

Automatic and Custom radio buttons
Determines whether the PROM file will be split automatically by the
PROM File Formatter (Automatic button enabled) or will be split as you
direct (Custom button enabled).

•

Currently Used Devices
Indicates the devices into which the PROM File Formatter data is
currently targeted.

When you have selected an option, click Next to continue the Split PROM
Wizard.
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Split PROM Wizard Dialog Box Options—Automatic
The Automatic selection option of the Split PROM Wizard selects the
minimum number of PROMs required to contain the data. If you selected
Automatic in the Split PROM Wizard dialog box, the dialog box shown in
the following figure appears.

Figure 4-9

Split PROM Wizard Fields—Automatic

The information in this dialog box is read-only; it indicates the devices into
which the PROM File Formatter divided the existing PROM File and the size
of each device.
Click Finish to complete the PROM Wizard.

Split PROM Wizard Dialog Box Options—Custom
The Custom selection option of the Split PROM Wizard allows you to
specify how PROM File Formatter will split the PROM data. If you selected
Custom in the Split PROM Wizard dialog box, the dialog box shown in the
following figure appears.
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Figure 4-10

Split PROM Wizard Fields—Custom

The Split PROM File dialog box for custom selection includes the following
options:
•

Bytes Required box
Indicates the size of the PROM file you are splitting or total number of
bytes to be allocated.

•

Bytes Available box
Indicates the number of bytes available in the set of devices you have
chosen.

•

Bytes Remaining box
Indicates the number of bytes that still need to be allocated.

•

Available Devices list box
Displays the PROM list, which provides a listing of available PROMs
and corresponding PROM sizes. You select devices in this list to add to
the Devices Used list.
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•

Devices Used list box
Displays the selected PROMs in the order they will receive the PROM
data.

•

> button
Adds the device currently selected in the Available Devices list to a
position under the device currently selected in the Devices Used list.

•

Move Up button
Moves the device currently selected in the Devices Used list one position closer to the top of the list.

•

Move Down button
Moves the device currently selected in the Devices Used list one position closer to the bottom of the list.

•

Remove button
Removes the entry currently selected in the Devices Used list from the
list.

•

Remove All button
Removes all entries from the Devices Used list box, clearing the box.

•

Back button
Returns to the previous Split PROM Wizard dialog box.

•

Finish
Closes the Split PROM Wizard and applies the splitting information to
the data currently displayed in the PROM description area.

Note: The files created by the Split PROM Wizard are not saved to disk
until you execute a Save command.

Status Bar (View Menu)
This command displays or hides the status bar, located at the bottom of the
PROM File Formatter window. The status bar provides command and
processing information and information about the PROM properties.
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Toolbar (View Menu)
This command displays or hides the toolbar located at the top of the PROM
File Formatter window. The toolbar displays several buttons, which you can
use to specify commands directly. Use the toolbar as an alternative to the
menu commands. See the “Toolbar” section of the “Getting Started” chapter
for descriptions.

Undo (Edit Menu)
This command reverses the last action you performed.
The following toolbar button executes the Undo command.
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Glossary of Terms
The following terms are defined to help you understand the PROM File
Formatter terminology used in this manual.

byte wide PROM
A PROM that is read one byte at a time. The other PROM type is a serial
PROM, which is read one bit at a time.

daisy chain
In the context of the PROM File Formatter, a data stream used to configure a
set of devices that are connected in series such that the DOUT pin of a device
in the daisy chain is connected to the DIN pin of the next device. You can
generate a daisy chain data stream by concatenating two or more bitstreams
(BIT files) together using the PROM File Formatter.

data stream
In the context of the PROM File Formatter, a data stream is a collection of
one or more concatenated BIT files used to implement a single user
application. To implement multiple applications, concatenate data streams
— one data stream per application — to form a multiple data stream PROM
file that allows you to reprogram a single FPGA or a daisy chain.

EXORmacs (Motorola)
A PROM file format supported by the Xilinx tools. Its maximum address is
16,777,216. This format supports PROM files of up to (8 x 16,777,216) =
134,217,728 bits.
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Express mode
FPGA configuration mode (XC5200 only) in which configuration data is
loaded into the FPGA in parallel; one byte per clock cycle instead of one bit
per clock cycle.

file selection area
The area located on the right side of the PROM File Formatter window. The
area presents a hierarchical view of the drives, directories, and BIT files in
your system. The area is used to locate and select the BIT files that the
PROM file will contain.

hexadecimal format (HEX)
An ASCII hexadecimal version of the PROM data. It has unlimited data
capacity.

loading direction
The direction in which data is stored on your PROM. In the Up direction, the
data is stored in ascending order, starting at a low address. In the Down
direction, the data is stored in descending order, starting at a high address.

MCS-86 (Intel)
An Intel PROM format supported by the Xilinx tools. Its maximum address
is 1,048,576. This format supports PROM files of up to (8 x 1,048,576) =
8,388,608 bits.

menu bar
The area located at the top of the PROM File Formatter window that
provides access to the menus. It includes the File, Edit, View, and Help
menus.

PROM
A programmable read only memory.
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PROM description area
The area located on the left side of the PROM File Formatter window. The
area shows the structure of your PROM file. It is a hierarchical view of the
data streams and BIT files in the PROM file.

PROM description (PDR) file
An ASCII report file listing all the data streams and BIT files used to
construct the PROM file, as well as the load direction and PROM file
splitting information. The PROM File Formatter uses this file to determine
the structure and properties you have specified for the PROM file.

PROM file
A file consisting of one or more BIT files (bitstreams) formatted into a
standard PROM file format. If generated using the PROM File Formatter, the
file is formatted in one of three industry-standard formats: Intel MCS-86,
Tektronics TEKHEX, or Motorola EXORmacs. The PROM file includes
headers that specify the length of the bitstreams, as well as all the framing
and control information necessary to configure the FPGAs. It can be used to
program one or more devices.

PROM File Formatter
The program used to format one or more bitstreams into an MCS-86,
TEKHEX, EXORmacs, or HEX format.

serial PROM
A PROM whose data is read serially, one bit at a time. The other PROM type
is a byte wide PROM, which is read one byte at a time.

status bar
An area located at the bottom of a window that provides information about
the commands that you are about to select or that are being processed.
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TEKHEX (Tektronix)
A Tektronix PROM format supported by Xilinx. Its maximum address is
65,536. This format supports PROM files of up to (8 x 65,536) = 524,288
bits.

toolbar
The area located under the menu bar at the top of your window. It contains a
series of buttons that you click to execute some of the most commonly used
commands. These buttons constitute an alternative to the menu commands.
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Keyboard Shortcuts
Use the following keyboard shortcuts to navigate and select objects on the
PROM File Formatter screen and to navigate in the Help tool.
The following table is a summary of the PROM File Formatter keyboard
shortcuts.
Table B-1

Keyboard Shortcuts

Key

Action

Ctrl N

Runs the File → New command.

Ctrl O

Runs the File → Open command.

Ctrl S

Runs the File → Save command.

Alt Enter

Runs the File → PROM Properties command.

Ctrl Z

Runs the Edit→ Undo command.

Ctrl R

Runs the Edit→ Redo command.

Ctrl X

Runs the Edit→ Cut command.

Ctrl C

Runs the Edit→ Copy command.

Ctrl V

Runs the Edit→ Paste command.

Alt ↑

Runs the Edit→ Move Up command.

Alt ↓

Runs the Edit→ Move Down command.

Tab

In the PROM File Formatter window, toggles the
keyboard focus between the PROM description area
and the file selection area. In a dialog box, traverses
forward through objects and highlights them.

Shift Tab

In a dialog box, traverses backward through objects
and highlights them.

Enter

Activates a selection button or a highlighted item in a
list.
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Table B-1

Keyboard Shortcuts

Key

B-2

Action

Delete

Deletes the selected file or data stream.

Arrow keys

Scrolls up or down inside selection boxes, including
menus. Also, scrolls up or down the hierarchical
display in the PROM description area or the file
selection area.

Alt Character

Selects a menu (for example, Alt F selects the File
menu).

Esc

Deselects a menu or exits a dialog box.
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Multiple Configuration Setups
This appendix describes programming setups that you can use to support
multiple applications in a system. Three possible scenarios are covered.
These are described in the following sections.
•

“Reconfiguring a Daisy Chain from a Serial PROM”

•

“Reconfiguring a Single Device or Daisy Chain from a Parallel PROM”

•

“Configuring Multiple Device Daisy Chains from One Parallel PROM”

Note: For information about Virtex configurations, see the Xilinx web page
(http://www.xilinx.com).

Reconfiguring a Daisy Chain from a Serial PROM
You can download multiple applications to a single device or to a daisy chain
of multiple devices in master serial mode from a serial PROM device. The
master serial mode forces you to reconfigure your FPGAs with the
applications in a fixed sequence (the sequence in which the data streams are
saved in the serial PROM).
1.

Use the PROM File Formatter to build a PROM file that includes a separate data stream for each application that you wish to implement in the
FPGA or daisy chain. Save it in serial PROM format. Each data stream
will have its own header and length count, which the FPGA or daisy
chain uses to determine when it has read in all the data for a particular
application.

2.

Burn the PROM file into a serial PROM device using a PROM
programmer.
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3.

If you are configuring a daisy chain, build the daisy chain of devices,
ensuring you connect the DOUT output of each slave device to the DIN
input of the next device. Refer to the connections given in The
Programmable Logic Data Book.

4.

If you want to configure a single device, connect the serial PROM
directly to the FPGA; if you want to configure a daisy chain, connect the
PROM to the master device of the daisy chain.

5.

Power up the daisy chain of devices.
The PROM’s internal address counters are reset upon power-up. The
FPGA or daisy chain reads the length count in the first data stream and
clocks the serial PROM a length count number of times to configure the
FPGA or daisy chain with the first application. At the end of the first
configuration cycle, the PROM internal address pointer is left pointing
to the end of the first data stream.

6.

Reconfigure the daisy chain by pulling the PROG pin of XC4000 and
XC5200 devices Low for at least 300 ns; pull the D/P pin of XC3000A
devices Low for at least 6 µs (microseconds).
This action causes the FPGA or daisy chain to read the next data stream
in the PROM.
If the PROM has been configured for active High Reset, you must tie the
RESET/OE pin to GND; if the PROM has been programmed for active
Low Reset, tie the RESET/OE pin to VCC.

Note: Do not use this procedure if there is any chance that your system
might be reset before you try to reprogram the FPGAs with the second
configuration. Any accidental system resets can cause the PROM’s internal
address counter to be reset to 0 also, which makes it point back to the first
data stream.
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Reconfiguring a Single Device or Daisy Chain from a
Parallel PROM
You can program a single device or daisy chain with multiple configurations
loaded from a parallel PROM. This method allows you to select the desired
application in any order by selecting the appropriate start address.

Planning the PROM Structure
1.

Use the PROM File Formatter to build a PROM file that includes one
data stream for each daisy chain that needs to be configured.

2.

Look at the numbers in the PROM description area to determine the
total number of bytes required for the largest data stream.

3.

Compute the number of address bits required to address this number of
bytes. For example, if the size of the largest data stream is 25,000 bytes,
then 15 address bits are needed to address them.

4.

Use the remaining high order bits as the external select bits to select the
data stream for the desired application.

Setting the PROM Properties
1.

Select File → PROM Properties.

2.

In the Format tab of the PROM Properties dialog box, select Byte Wide
in the Type field.

3.

In the Data Streams tab of the PROM Properties dialog box, enter the
starting address for each data stream in the PROM file. Set the address
such that the desired data stream can be selected out of 2n data streams
by asserting n address bits.
For example, a single data bit can select two different applications. If the
PROM file contains two data streams, select the starting addresses for
the two applications such that they differ by only one address bit; this is
typically the high order address bit.

4.

Save the PROM file.
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Implementing the Setup
1.

Burn the PROM file into a parallel PROM device using a PROM
programmer.

2.

Connect the components on your board as shown in The Programmable
Logic Data Book.

3.

To control the n address bits, you can use either a microcontroller or a
state machine implemented in an XC9500 CPLD.

4.

To reconfigure the daisy chain, pull the PROG pin of XC4000 and
XC5200 devices Low for at least 300 µs; pull the D/P pin of XC3000A
devices Low for at least 6 µs.

Example
This example explains how to use a microcontroller or CPLD device to
configure a daisy chain for four separate functions using four data streams
stored on the parallel PROM. The daisy chain is 12,500 bytes long.
Because the daisy chain requires 12,500 bytes of configuration bits, 14
address bits are required to address the data (214=16,384 bytes). You must
use two external selection bits to select each of the four data streams
individually. Use the two high order bits of each data stream starting address
for this purpose (bits 14 and 15).
Table C-1 Data Stream Addressing—Single Device or Daisy
Chain Example
Data Stream

Select Bits

Starting Address

Ending Address

1

00

00 00000000000000

00 11111111111111

2

01

01 00000000000000

01 11111111111111

3

10

10 00000000000000

10 11111111111111

4

11

11 00000000000000

11 11111111111111

To configure the FPGA daisy chain on power-up with the first application,
the microcontroller or CPLD must drive the two high order address bits to 00
to select data stream #1 for the first application. To reconfigure FPGA or
daisy chain for application #4, drive the two high order address bits to 11 and
assert the appropriate REPROGRAM signal.
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Configuring Multiple Device Daisy Chains from One
Parallel PROM
Some applications might require that you store the configuration data for
multiple daisy chains of FPGAs on the same parallel PROM device. To
implement such a setup, use additional logic to address the different daisy
chains, to hold all unconfigured daisy chains in reset mode, and to tristate the
configured daisy chains while another chain is being configured.

Planning the PROM Structure
1.

Use the PROM File Formatter to build a PROM file that includes one
data stream for each daisy chain that needs to be configured.

2.

Determine the total number of bytes required for the largest data stream.

3.

Compute the number of address bits required to address this number of
bytes. For example, if the size of the largest data stream is 25,000 bytes,
then 15 address bits are needed to address them.

4.

Use the remaining high order bits as the external select bits to select the
data stream for the desired application.

Setting the PROM Properties
1.

Select File → PROM Properties.

2.

In the Format tab of the PROM Properties dialog box, select Byte Wide
in the Type field.

3.

In the Data Streams tab of the PROM Properties dialog box, enter the
starting address for each data stream in the PROM file. Set the address
such that the desired data stream can be selected out of 2n data streams
by asserting n address bits.
For example, a single data bit can select two different applications. If the
PROM file contains two data streams, select the starting addresses for
the two applications such that they differ by only one address bit; this is
typically the high order address bit.

4.

Save the PROM file.
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Implementing the Setup
1.

Burn the PROM file into a parallel PROM device using a PROM
programmer.

2.

Connect the components on your board as shown in The Programmable
Logic Data Book.

3.

To control the n address bits, you can use either a microcontroller or a
state machine implemented in an XC9500 CPLD.

4.

As each daisy chain is being configured, use the microcontroller or the
state machine to hold unconfigured daisy chains in reset mode by
pulling RESET/INIT Low and to tristate the address lines leading to all
configured daisy chains.

5.

Use the microcontroller to hold the second daisy chain in reset mode
while you configure the first daisy chain. Keep the second daisy chain in
Reset mode until the DONE signal of the first daisy chain goes High.
When the DONE signal goes High, the first daisy chain has completed
configuration.

6.

When the DONE signal for the first device goes High, the address pins
of the master device in the first daisy chain must be tristated while the
second chain is allowed to configure. This step prevents contention with
the active outputs of the first daisy chain.

Example
This example explains how to use a microcontroller or CPLD device to
configure four daisy chains using four data streams stored on the parallel
PROM. The size of the largest data stream is 12,500 bytes.
Because the largest of these daisy chains requires 12,500 bytes of
configuration bits, 14 address bits are required to express the size of the data
(214=16,384 bytes). You must use two external selection bits to select one
out of the four data streams. Use the two high order bits of each data stream
starting address for this purpose.
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Table C-2
Example

Data Stream Addressing—Multiple Daisy Chain

Data Stream

Select Bits

Starting Address

Ending Address

1

00

00 00000000000000

00 11111111111111

2

01

01 00000000000000

01 11111111111111

3

10

10 00000000000000

10 11111111111111

4

11

11 00000000000000

11 11111111111111

1.

To configure daisy chain #1 on power-up, the microcontroller or CPLD
must drive the two high order address bits to 00 to select data stream #1
for the first application.

2.

Use the microcontroller or CPLD to hold the other three unconfigured
daisy chains in Reset mode by pulling RESET/INIT Low.
To hold an XC3000A device in Reset mode, hold the RESET pin Low;
for the XC4000 and XC5200 devices, hold the INIT pin Low.

3.

When the DONE pin goes High on the first daisy chain, the daisy chain
is configured. The microcontroller or CPLD must respond by tristating
the address lines leading to the master device of the first daisy chain.
The controller also drives the 01 value on the high-order address bits to
select the second data stream, then releases RESET on the second daisy
chain so that it can configure.

4.

Repeat the previous step for the third daisy chain after DONE goes High
on the second daisy chain, this time tristating the address pins on both
the first and second daisy chain, driving a value of 10 on the high order
address bits, and releasing the RESET on the third daisy chain.

5.

For the fourth daisy chain, after DONE goes High on the third daisy
chain, tristate the address pins on the first, second, and third daisy
chains, drive a value of 11 on the high order address bits, and release
RESET on the fourth daisy chain.
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