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Certification

Hewlett-Packard Company certifies that this product met its published
specifications at the time of shipment from the factory.  Hewlett-Packard
further certifies that its calibration measurements are traceable to the United
States National Institute of Standards and Technology, to the extent allowed
by the Institution’s calibration facility, or to the calibration facilities of other
International Standards Organization members.

Warranty

This Hewlett-Packard instrument product is warranted against defects in
material and workmanship for a period of one year from the date of shipment,
except that in the case of certain components listed in General Information

of this manual, the warranty shall be for the specified period.  During the
warranty period, Hewlett-Packard Company will, at its option, either repair or
replace products that prove to be defective.

For warranty service or repair, this product must be returned to a service
facility designated by HP.  Buyer shall prepay shipping charges to HP and HP
shall pay shipping charges to return the product to Buyer.  However, Buyer
shall pay all shipping charges, duties, and taxes for products returned to HP
from another country.

HP warrants that its software and firmware designated by HP for use with an
instrument will execute its programming instruction when property installed
on that instrument.  HP does not warrant that the operation of the
instrument, or software, or firmware will be uninterrupted or error free.
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Limitation Of Warranty

The foregoing warranty shall not apply to defects resulting from improper or
inadequate maintenance by Buyer, Buyer-supplied software or interfacing,
unauthorized modification or misuse, operation outside the environmental
specifications for the product, or improper site preparation or maintenance.

No other warranty is expressed or implied.  HP specifically disclaims

the implied warranties of merchantability and fitness for a particular

purpose.

Exclusive Remedies

The remedies provided herein are buyer’s sole and exclusive remedies.

HP shall not be liable for any direct, indirect, special, incidental, or

consequential damages, whether based on contract, tort, or any other

legal theory. 

Assistance

Product maintenance agreements and other customer assistance agreements
are available for Hewlett-Packard products.

For any assistance, contact your nearest Hewlett-Packard Sales and Service
Office.  Addresses are provided at the back of this manual.
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Product Overview

HP B3475A Embedded MIPS Interface Software provides users an interface
of integrated debugging environment, as illustrated below. 

HP B3745A Embedded MIPS Interface Software consists of two software
components interfacing individual debugging tasks; the PC Trace for tracing
PC of user program and the Software Analyzer for controlling the HP 16500B
Logic Analyzer.
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The PC Trace is a part of HP B3745A Embedded MIPS Interface Software,
which performs tracing of program counter (PC) of user programs.

With the PC Trace, you can: 

• Trace an execution flow with the internal cache active on the processor.

• Define a variety of trace conditions.

• Configure the HP E3492A Processor Probe.

• Set hardware breakpoints.

Use the PC Trace with a debugger started, since the operations such as
start/stop of the program execution and reference to variables are all
accomplished through the debugger available from a third party
manufacturer. 

For controlling the HP 16500B Logic Analyzer, this document’s scope is
limited to how to connect your computer to the HP 16500B. See "Software
Analyzer User’s Guide" for detailed operation of the Software Analyzer to
control HP 16500B Logic Analyzer. Be sure that no further installation is
required to settle the Software Analyzer, because it was already installed
when you completed installing HP B3745A product.
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In This Book

This book shows you how to use the PC Trace. It contains the following
chapters:

• Chapter 1 is a brief tutorial that uses sample files to show you the steps
you’ll generally take when using the PC Trace.

• Chapter 2 explains more on the PC Trace basics described in the
previous chapter.

• Chapter 3 describes the commands in the PC Trace windows, the
General-Purpose ASCII (GPA) file format, and messages that can appear
when using the PC Trace.

• Chapter 4 describes most the common problems that can occur when
using the PC Trace, why they happen, and how to solve them.

• Chapter 5 shows you how to install the PC Trace. It contains instructions
for personal computers running MS Windows as well as for workstations
running the UNIX operating system.
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Tutorial

Before following the instructions in this tutorial, make sure you have: 

• Installed the HP B3745A Embedded MIPS Interface Software.

• Installed and started a debugger available from a third party
manufacturer.

• Installed the target system with the HP E3492A Processor Probe
properly connected.

When you use the HP E3492A Processor Probe with the HP 16500B Logic
Analyzer, make sure you also have:

• Installed the appropriate state analyzer module, with version V02.00 or
greater software, into the HP 16500B Logic Analyzer mainframe (refer to
the documentation that comes with the logic analysis module).

• Installed the HP 16500L LAN Interface Module into the HP 16500B Logic
Analyzer mainframe, and connected the HP 16500B to your LAN (refer
to your HP 16500L documentation).

• Installed the HP 16500B system software, version V02.00 or greater.

• Installed the HP E2450A Symbol Utility Software, version V02.00 or
greater, in the HP 16500B (refer to the installation instructions that came
with the media).

This tutorial uses sample files to show the steps you take when using the PC
Trace. 

• Step 1. Start the PC Trace 

• Step 2. Configure the Processor Probe 

• Step 3. Load the symbol database 

• Step 4. Set up the trigger and capture data 
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Step 1. Start the PC Trace

1 Start the PC Trace by double-clicking on the PC Trace icon. 

Successful operation brings up the Main Window, followed by Opening
Message dialog box, and "LAN Connection" dialog box. 

2 In the "LAN Connection" dialog box, enter the HP E3492A LAN
address (or select it from the list of previously entered names). 

One way to find the correct HP E3492A LAN address is to look up the file
\NFS\HOSTS (for PC) or /etc/hosts (for WS). The file should reside in the
local computer which the PC Trace is running on.

3 Select the appropriate "Network Protocol". 

4 Click the "Connect" button. 

After you click the Connect button, the PC Trace window appears: 

• The menu bar contains three menus: 

– File menu provides loading symbol file, copying trace file,
loading/storing trace, and programming/erasing file on FLASH
device file functions. 

– Trace menu controls trace settings and trace execution. 

– Setting menu allows you to configure the Processor Probe, BNC
port, and viewing options of trace measurement results. 

Tutorial
Step 1. Start the PC Trace
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If you are not able to connect to the HP E3492A, refer to "If you have LAN
connection problems" in the "Common Problems" section. 

Use Rightarrow icon (or Next) to scroll the trace one page downward. 

Use leftarrow icon (or Prev) to scroll the trace one page upward.

Use Find icon (or Find) to search the character string specified in the box
placed left side of the icon. 

or Prev

or Next

or Prev

or Find

Tutorial
Step 1. Start the PC Trace
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Step 2. Configure the Processor Probe

You can configure the Processor Probe  to acquire the trace you desire. 

By default, the PC Trace starts configuring the Processor Probe as follows: 

• Run from Target Reset 

• Restricted to real time runs 

• Endian after Reset is Big endian 

Follow the steps below to change the Processor Probe configuration: 

1 In the PC Trace window, choose the Setting→Configuration...
command. 

Processor Probe Configuration dialog box appears. 

2 In the Processor Probe Configuration dialog box, click the buttons
according to your configuration. 

For details on configuring the Processor Probe, refer to
"Setting→Configuration..." in Chapter 3.

Tutorial
Step 2. Configure the Processor Probe
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Step 3. Load the symbol database

A sample demo program is used for this tutorial.   It has already been
compiled and linked into the ELF file named "main.x".  You need to transfer
this ELF file to the PC Trace in order to use its symbols. 

1 In the PC Trace window, choose File→Object Download... command. 

Object Download dialog box appears.

2 In Object File field, enter the object file name. 

"C:\hpcol\samples\r39pp\main.x"

"/usr/hpcol/<platform>/samples/r39pp/main.x"

You can click Browse... button to bring up Browser window. 

3 Check "Symbol" for "Attribute" field.

4 To load the symbol database, click on Load. 

Note It is recommended to reset the HP E3492A Processor Probe from your
debugger before loading your object file.

Tutorial
Step 3. Load the symbol database
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Step 4. Set up the trigger and capture data

After loading the symbol database, you are ready to perform trace
measurement.  The final step of this tutorial shows you how to set up
triggering and how to view trace data.

The trigger used here is "Always", which triggers capturing trace data at any
condition.  See "PC Trace Window Commands" for other triggers available
with the PC Trace.

Before you start capturing trace data, be sure that the sample program
(main.x ) is downloaded from your debugger and is running on your target
system.

In the PC Trace Window,

1 Choose Trace→Always command.

After a few seconds, trace result is stored in the trace memory of the
Processor Probe.

2 Choose Settings→Symbol/Source→Symbol command.
The trace list with symbols appears in the PC Trace window.

The PC Trace window can access a set of consecutive 1024 states at a time.
We call it a "page". Within a page, you can scroll down/up by clicking the
scroll bar.  Click on Prev or Next icon to display previous/next page.

Specifying the search string in the entry buffer and clicking the Find icon
refreshes the screen page to begin with the line including the character
string. You can, however, search the character string within the current page
(1024 states).

You may want to display other kind of information in the PC Trace window.
"PC Trace Window Commands" can tell you how.

This concludes the PC Trace tutorial.

Tutorial
Step 4. Set up the trigger and capture data
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Using the PC Trace

This part describes the tasks you will perform when using the PC Trace: 

• To Compile and Place Symbols in the Object File 

• To Start and Exit the PC Trace 
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To Compile and Place Symbols in the

Object File   

• Compile, assemble, and link your program using the "generate
symbol file" option of your language tools. 

For Greenhills C CROSS MIPS COMPILER/ASSEMBLER, use "-g" option. 

Refer to your software development tool documentation for information on
generating ELF files. 

Note Be sure to generate your object file WITHOUT optimization option: if an
optimized object file is used, the PC Trace possibly fails in viewing a trace list
in a proper format.

Using the PC Trace
To Compile and Place Symbols in the Object File   
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To Start and Exit the PC Trace

This section shows you how: 

• To start the PC Trace interface 

• To connect to an HP 16500B 

• To connect to an HP E3492A

• To exit the PC Trace 

Using the PC Trace
To Start and Exit the PC Trace
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To start the PC Trace interface 

• Click the "Embedded MIPS Interface" icon. 

You can also start the PC Trace interface from the command line.  The
"r39pp" command has the following syntax: 

r39pp [-V] [-?] [-a <ip_address>] [-t <transport>]
[-f <file>]

-V Displays the version information of the current
software. 

? Displays the usage summary of the software. 

-a <ip_address> Specifies the hostname or equivalent Internet (IP)
Address of the HP E3492A.  IP addresses are entered
in integer dot notation (for example, 15.6.35.253). 

-t <transport> This option is effective for only on personal computers
running MS windows 3.1. It lets you identify the
protocol of your network. You should choose
[WINSOCK1.1]. The transport types can be specified in
upper or lower case characters and only a significant
number of characters need be specified (for example,
"WINSOCK1.1", "winsock", and "w" are all equivalent). 

-f <file> Specifies the file of interest for debugging with the PC
Trace. 

Using the PC Trace
To Start and Exit the PC Trace
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To connect to an HP 16500B

1 In the Main window, choose the Settings→Connect→16500B
connect... command. 

Note that the "Connect" menu option is grayed out if you are already
connected to an HP 16500B.  If you wish to connect to a different HP 16500B,
exit the interface and start it again.

2 Enter the hostname or Internet (IP) address of the HP 16500B in the
"16500B LAN Address" box. 

3 Select the appropriate "Network Protocol". 

4 Click the "Connect" button. 

If you are not able to connect to the HP 16500B, refer to "If you have LAN
connection problems" in the "Common Problems" section.

 

Using the PC Trace
To Start and Exit the PC Trace
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To connect to an HP E3492A

1 In the Main window, choose the Settings→Connect→E3492A
connect... command. 

Note that the "Connect" menu option is grayed out if you are already
connected to an HP E3492A.  If you wish to connect to a different HP
E3492A, exit the interface and start it again.

2 Enter the hostname or Internet (IP) address of the E3492A in the
"E3492A LAN Address" box. 

3 Select the appropriate "Network Protocol". 

4 Click the "Connect" button. 

If you are not able to connect to the HP E3492A, refer to "If you have LAN
connection problems" in the "Common Problems" section. 

To exit the PC Trace

• In the Main window, choose the File→Exit command. 

Using the PC Trace
To Start and Exit the PC Trace
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Reference

This part describes: 

• Main Window Commands 

• PC Trace Window Commands 

• Messages 
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Main Window Commands 

The following commands can be chosen from the menu bar in the Main
window: 

• File→Download... 
• File→Exit 
• Settings→Connect→E3492A connect... 
• Settings→Connect→16500B connect... 
• Settings→Source View→PC Trace window... 
• Settings→Source View→HP 16500B Trace List window...

Reference
Main Window Commands 
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File→Download...  

Downloads files to the HP 16500B. 

This command lets you download files, typically ELF files, to the HP 16500B.
ELF files are downloaded to rebuild the symbol database. 

See the Software Analyzer User’s Guide for details. 

File Download Dialog Box

Local File Specifies the local file to be downloaded to the HP 16500B. 

Browse... Opens a dialog box that you use to select the local file.

16500B File Specifies where the file is to be placed in the HP 16500B
file system.  Type the HP 16500B path. 

Download Starts the download, and may bring up a "working" dialog
which reports on the number of bytes transferred. 

Cancel Aborts the file download and closes the window. 

Reference
Main Window Commands 
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File→Exit 

Exits the PC Trace. 

Reference
Main Window Commands 
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Settings→Connect→E3492A connect...  

Specifies and makes the LAN connection to the HP E3492A. 

LAN Connection Dialog Box

This dialog also appears when you have not specified the HP E3492A LAN
address (and protocol) in the command line that is used to start the PC
Trace. 

E3492A LAN
Address

Specifies the hostname or equivalent Internet (IP)
Address of the HP E3492A.  IP addresses are
entered in integer dot notation (for example,
15.6.35.253). 

Network Protocol This option is only present on personal computers
running MS Windows 3.1.  It lets you identify the
protocol of your network. You should choose
[WINSOCK1.1]. 

Connection
Timeout

Specifies the number of seconds to wait for the 
HP E3492A connection.  Control of the interface
returns when the connection is made or when the
timeout occurs.  Timeout values can be from 3 to
300 seconds. 

Reference
Main Window Commands 
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Connect Attempts the connection to the specified 
HP E3492A.  If you are not able to connect to the
E3492A, refer to "If you have LAN connection
problems" in the "Common Problems" chapter. 

Cancel Closes the dialog box without connecting. 

Reference
Main Window Commands 
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Settings→Connect→16500B connect...   

Specifies and makes the LAN connection to the HP 16500B. 

LAN Connection Dialog Box

16500B LAN
Address

Specifies the hostname or equivalent Internet (IP)
Address of the HP 16500B.  IP addresses are
entered in integer dot notation (for example,
15.6.35.253). 

Network Protocol This option is only present on personal computers
running MS Windows 3.1.  It lets you identify the
protocol of your network. You should choose
[WINSOCK1.1]. 

Connection
Timeout

Specifies the number of seconds to wait for the 
HP 16500B connection.  Control of the interface
returns when the connection is made or when the
timeout occurs.  Timeout values can be from 3 to
300 seconds. 

Connect Attempts the connection to the specified 
HP 16500B.  If you are not able to connect to the
HP 16500B, refer to "If you have LAN connection
problems" in the "Common Problems" chapter. 

Cancel Closes the dialog box without connecting. 

Reference
Main Window Commands 
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Settings→Source View→PC Trace window...  

Specifies the source file search path for the PC Trace and  Source window
settings. 

Source View Settings Dialog Box 

Source Path Lets you enter a source path to be inserted in the list.
When looking for the source file to display in the PC
Trace window, the PC Trace searches the listed
directories in the same order as they appear. 

Insert Inserts the source path into the list, either before the
highlighted line or at the end of the list if no line is
highlighted. 

Delete Deletes the highlighted source path from the list.  The
deleted source path is copied to the entry box in case
you want to insert it into a different place in the list. 

Tab Width Sets the number of spaces between tab stops.  Values
may be from 1 to 32. 

Line Numbers Toggles line numbers ON or OFF. 

OK Changes the settings, and closes the dialog box. 

Cancel Closes the dialog box without changing the settings. 

Reference
Main Window Commands 

3-9



Settings→Source View→HP 16500B Trace List
window...

Specifies the source file search path for the HP 16500B and Source window
settings.

Refer to the "Software Analyzer User’s Guide".

Reference
Main Window Commands 
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PC Trace Window Commands 

The following commands can be chosen from the menu bar in the PC Trace
window: 

• File→Load Executable... 
• File→Copy Trace List... 
• File→Trace Data... 
• Trace→Always 
• Trace→After() 
• Trace→About() 
• Trace→Before() 
• Trace→Condition... 
• Trace→Trace Again 
• Trace→Trace Halt 
• Trace→Trace Mode→RealTime 
• Trace→Trace Mode→Non-realTime 
• Settings→Configuration... 
• Settings→BNC... 
• Settings→Symbol/Source→Symbol 
• Settings→Symbol/Source→Mnemonic 
• Settings→Symbol/Source→Source Mixed 
• Settings→Symbol/Source→Source Only 
• Settings→Symbol/Source→Compress 

Reference
PC Trace Window Commands 
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File→Load Executable...  

Downloads a file to the PC Trace and/or the HP E3492A.

This command lets you download symbol information to the PC Trace.  Also
this command can be used to download object files, typically ELF files, to the
HP E3492A. ELF files are downloaded  to rebuild the symbol database. 

Download Dialog Box

Object File Specifies the local file to be downloaded to the HP E3492A. 

Browse... Opens a dialog box that you use to select the local file. 

Attribute Specifies the way to download the local file. Select "Symbol
Only" when you wish to download only symbol information
to the PC Trace, "Binary Only" when binary code to 
HP E3492A. 

Select both of the "Symbol" and "Binary" when you wish to
download both of the symbol information and binary code.
You only have to download the binary code once either on
the debugger or on the PC Trace. On the other hand, you
have to download the symbol information on both of the
debugger and the PC Trace. If you want to add the symbol
information to the information previously loaded, select
"Symbol", then "Symbol Append".

Reference
PC Trace Window Commands 
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Load Starts downloading, and may bring up a "working" dialog
which reports the number of bytes transferred. 

Cancel Aborts downloading and closes the window. 

Note It is recommended to reset the HP E3492A Processor Probe from your
debugger before loading your object file.

Reference
PC Trace Window Commands 
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File→Copy Trace List... 

Stores trace results as a text file. You can view the contents of the text file
with a text editor, but you cannot reload it on the PC Trace.

This command lets you copy trace results with the current display mode to
the local computer. You can specify a range to be copied.

Display Copy Dialog Box

Destination
File

Specifies the local file to be copied. 

Browse... Opens a dialog box that you use to select the local file. 

Start State Specifies the state where copying starts. 

End State Specifies the state where copying ends. 

Copy Starts copying. 

Cancel Aborts copying and closes the window. 

Reference
PC Trace Window Commands 
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File→Trace Data... 

Stores trace results as a binary file. Or loads and displays the contents of the
specified binary file. You cannot view the contents of the binary file with a
text editor. The stored binary file contains neither symbol information nor a
source file. You, therefore, have to reconfigure the symbol information and
specify the proper search path for the source file to view the contents of the
binary file with the symbols and the source.

This command lets you store and load trace results to your local computer. 

The number of loaded or stored states appears in the dialog box when  the
data manipulation successfully completes. 

Trace Data load/store Dialog Box

File Specifies the local file to be loaded or stored 

Browse... Opens a dialog box that you use to select the destination
file . 

Load Starts loading. 

Store Starts storing. 

Close Aborts copying and closes the window. 

Reference
PC Trace Window Commands 
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File→FLASH Operations 

Controls and performs programming/erasing operation on the flash ROM. 

FLASH Operations Dialog Box

Operation Select "Program" or "Erase" depending on the operation
you want to perform. 

FLASH Device selection field is used to define the flash ROM area in your
target system.  Thus, after you define this field, you don’t have to modify any
of the information till you change the FLASH device.

Algorithm Specifies the programming algorithm for the
device. The PC Trace supports four
algorithms:"Intel Quick-Pulse", "Intel Auto", "AMD
5V Embedded", and "AMD 12V Embedded".

Reference
PC Trace Window Commands 
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Bus Width Specifies the bus width for your target
microprocessor. Selectable items are "Byte"(8 bit),
"Word"(16 bit), and "Long"(32 bit). For R3900
series microprocessor, always select "Long".

Device Width Specifies the bus width for the flash ROM.
Selectable items are "Byte"(8 bit) and "Word"(16
bit).

Start Address Specifies the starting address of the flash ROM.

Size(bytes) Specifies the memory size of the flash ROM in
bytes.

In Sectors to Erase field, you can specify the sector(s) of the flash ROM you
want to erase.  This field is available only for the devices programmed by
"Intel Auto" or "AMD 5V Embedded" algorithm.

Erase All Sectors Check here when you erase all sectors in the flash
device. This box gets active when you select "AMD
5V Embedded" algorithm.

Address Enter the starting address of the sector you want
to erase.

File: Enter the file name containing the program to be
downloaded.

Browse... Opens a dialog box that you use to select the file to
be downloaded. 

OK Executes program/erase operation and closes this
window. 

Apply Executes program/erase operation without closing
this window. 

Cancel Discards all the information specified within the
dialog box and closes this window. 

Reference
PC Trace Window Commands 
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Trace→Always 

Specifies no trigger conditions. The tracing starts immediately after this
command is chosen.

This command lets you execute tracing all the states continuously. 

Trace→After() 

Specifies a trace position so that the address specified in the entry buffer will
be traced at the top of the trace list. The operation to that address may be
instruction execution, fetch, read, or write.

You can also specify a symbol and filename:#line number instead of address
information.

Trace→About()  

Specifies a trace position so that the address specified in the entry buffer will
be traced at the center of the trace list. The operation to that address may be
instruction execution, fetch, read, or write.

You can also specify a symbol and filename:#line number instead of address
information.

Reference
PC Trace Window Commands 
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Trace→Before() 

Specifies a trace position so that the address specified in the entry buffer will
be traced at end center of the trace list. The operation to that address may be
instruction execution, fetch, read, or write.

You can also specify a symbol and filename:#line number instead of address
information.

Reference
PC Trace Window Commands 
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Trace→Condition... 

Specifies conditions for trace triggering and hardware break points.

This command lets you specify conditions for trace triggering. 

Trigger Condition Dialog Box

Entry Displays the specified trace trigger conditions and
hardware break points (Instruction Address Break,
Processor Bus Break). . 

 An entry titled "Instruction" defines an instruction
address for trace trigger and/or hardware
breakpoint. An entry titled "Processor Bus" defines
the address, the data and the attribute also for
trace trigger and/or hardware breakpoint. 
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An instruction trace trigger is generated when the
instruction at the specified logical address is being
executed. An instruction address break is also
generated if "Break on trigger" check box is
selected. If the break occurs, the instruction is not
performed. 

A processor bus trace trigger is generated when
the specified cycle (fetch, read, or write) occurs at
the specified address with the specified data. A
processor bus break is also generated if "Break on
trigger" check box is selected.  Be aware that the
specified address is treated as physical address
since the address comparation is done on the
processor bus not in the core.  Fetch or read cycles
from cached address range will not generate a
trace trigger or a break. 

Trace trigger starts PC trace in accordance with
the specified trigger position. An instruction
address break or a processor bus break stops the
user program and transfers the execution to the
monitor program. 

Address Specifies the address where trigger condition is
stored.

Data Specifies the data where triggering starts. 

Attribute Specifies the type of data access for triggering, "L"
for triggering on data loading, "S" on data storing,
and "F" on op-code prefetching.

Break On trigger Specifies if triggering causes a break into  the
monitor. This enables the trace condition to work
as a Hardware Break.

Set Set the trigger condition. The condition will appear
in the Entry Display Box. 

Clear Clears the trigger condition you specified
(highlighted in the Entry Display Box). 
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Clear all Clears all the trigger condition in the Entry Display
Box at once. 

Trigger position Specifies the position where the condition meets
and trace trigger occurs. 

OK Saves the conditions specified and closes this
dialog box. 

Cancel Closes this dialog box without saving the newly
specified conditions. 
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Trace→Trace Again 

Executes or restarts the trace with the trace conditions unchanged. 

Trace→Trace Halt 

Halts the trace measurement. 

Trace→Trace Mode→RealTime 

Executes the trace measurement in realtime mode which allows  the user
program runs in realtime. 

In this mode, if successive indirect register jumps occur within 30 cycles, the
PC  output of the first jump will be lost. Then, the trace list will not be
displayed  until the next complete PC output. 

Trace→Trace Mode→Non-realTime 

Only when successive indirect register jumps occur within 30 clock cycles,
temporary stalls the pipeline on the processor before the completion of the
PC output for the first indirect register jump. This slightly slows the
execution, but ensures a completion of the PC tracing.

In this mode, user program is not executed in realtime even PC tracing is
halted. 
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Settings→Configuration... 

Specifies the configuration for the HP E3492A Processor Probe. 

This command lets you configure HP E3492A Processor Probe. 

Processor Probe Configuration Dialog Box

Restrict to real
time runs?

Specifies whether or not to restrict the user
program to real time runs. When selected, this
option temporarily disables monitor break
commands including ones for displaying/modifying
registers or target memory, so that realtime
execution of the user program will be assured.

Run from target
reset?

Specifies whether or not to wait for a reset signal
from the target system on resetting user program.
When selected, user program execution starts after
a reset signal from the target system is detected.
When not selected, user program execution starts
at the point of reset vector.

Endian after
reset?

Selects a type of endian after resetting. Refer to
the user’s guide of microprocessors. 

OK Saves the configurations specified and closes this
dialog box. 

Cancel Closes this dialog box without saving the newly
specified configurations. 
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Settings→BNC... 

Specifies the configuration for the BNC port. 

This command lets you configure HP E3492A Processor Probe’s BNC port. 

BNC configuration Dialog Box

Enable driving
break signal?

When selected, the Processor Probe outputs the
signal on the "TRIGGER OUT" BNC port as it
breaks.

Enable receiving
break signal?

When selected, the Processor Probe breaks as the
"TRIGGER IN" BNC port receives a signal.

Enable driving
PC trace trigger
signal?

When selected, the Processor Probe outputs the
signal on the "TRIGGER OUT" BNC port as a
trigger condition meets.

Enable receiving
PC trace trigger
signal?

When selected, the Processor Probe generates a
trigger as the "TRIGGER IN" BNC port receives a
signal. 
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Settings→Symbol/Source→Symbol 

Toggles displaying symbol information in the PC Trace window.
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Settings→Symbol/Source→Mnemonic 

Displays inverse-assembled mnemonics in the PC Trace window. 

Following messages are shown in the mnemonic column in the PC Trace
window: 

Mnemonics

Shown for an execution state with known address. 

Sequence

Shown for an execution state with unknown address. The address is
unknown in the following cases;

• between the trace start and the first branch/ jump.

• between the two consecutive register indirect branches occur within 30
clock cycles and the next branch/jump with the PC output completed.

Pipeline Stall

Shown for an stall state. 

Jump/Branch Taken

Shown for a jump/branch state. 

Exception

Shown for an exception state. In the address column, also shown the address
of the instruction where the exception occurs. 

Debug Mode

Shown for a monitoring state. 
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Settings→Symbol/Source→Source Mixed 

Displays symbols and/or mnemonics with source codes in the PC Trace
window. 

Settings→Symbol/Source→Source Only 

Displays only source codes in the PC Trace window. 

Settings→Symbol/Source→Compress 

Displays the trace results, with "Pipeline Stall" states removed, in the PC
Trace window.

Reference
PC Trace Window Commands 

3-28



Messages

Describes the messages that can appear when using the PC Trace. 

!Address is not specified

The Trace→After(), Trace→About(), or Trace→Before() cannot execute
because no address has been specified. Be sure to specify the reference
address in the entry buffer to acquire trace data.

Invalid PC trace data file

The format of the file specified in the Trace Data load/store dialog box is
invalid for loading trace data. The file may be a text format file. Make sure
the specified file has once been stored with the File→Trace Data...
command, not with the File→Copy Trace... command.

Invalid register status

An invalid trigger condition has been specified. Make sure an appropriate
trigger condition is defined in the Trigger Condition dialog box.

Invalid status number

The File→Copy Trace... command has failed to copy the trace result since an
invalid state number has been specified. Make sure appropriate state
numbers are specified in both of the "Start State" and "End State" fields.

Invalid symbol: <symbol name>

An invalid symbol has been specified. In the PC Trace window, make sure an
appropriate symbol is specified in the entry buffer. In the Trigger Condition
dialog box, make sure an appropriate address is specified in the "Address"
field.

No address specified

No trigger condition can be specified in the Trigger Condition dialog box
since no address has been previously specified. Specify the address for the
trigger condition in the "Address" field.
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No trace data is available

No trace data is available to be stored in the file specified in the Trace Data
load/store dialog box. To store trace data, first define an appropriate trigger
condition to acquire trace data.

Specify erase all or sector address

The flash ROM cannot be erased in the FLASH Operations dialog box
because no sector has been specified in the Sectors to Erase field. Specify the
starting address of the sector to be erased in "Address". Or click "Erase All
Sectors" (when being active), then "OK".

Specify object file name

No program can be downloaded in the FLASH Operations dialog box since no
filename has been previously specified. Specify the name in "File" of the file
storing the program to be downloaded. Selecting "Browse" invokes the dialog
box, where you can select the file to be downloaded.

Specify size in byte

No size in byte has been specified in the FLASH Operations dialog box. This
is required to define FLASH device to use.

Specify start address

No starting address has been specified in the FLASH Operations dialog box.
This is required to define FLASH device to use.

State Number is not specified

No state/character string can be searched with the Find icon in the PC Trace
window since no item has been specified in the entry buffer. First specify the
state/character string to be searched in the entry buffer.

Target Error

An error has occurred in the target system. The message refers also to the
response from the processor probe.
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Common Problems 

This part describes the solutions to common problems that can occur when
using the PC Trace. 

• If you have LAN connection problems 

• If your HP E3492A is in use

• If your HP 16500B is in use 

• If there is no source code in the PC Trace window

• If it takes longer to copy trace data than you except

• When it takes longer to program/erase flash ROM than you except
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If you have LAN connection problems  

 Verify your PC networking is working correctly. 

Some possible methods are:

ping <another_computer_on_your_network>

ftp <another_computer_on_your_network>

Since Windows networking is required to run this product, verify your
Windows networking configuration.  Most networking packages install a
Windows networking device driver in the SYSTEM.INI file.  If this is not done
correctly, DOS mode applications may run successfully, but the product will
still fail under Windows.

Verify your HP E3492A networking configuration.

Try to "ping" the HP E3492A from your computer:

ping <hostname or IP_address>

If the HP E3492A does not respond to a "ping", you need to verify its Internet
(IP) Address.

Verify your HP 16500B networking configuration. 

Try to "ping" the HP 16500B from your computer:

ping <hostname or IP_address>

If the HP 16500B does not respond to a "ping", you need to verify its Internet
(IP) Address.  To do this, go to the HP 16500B and look at the Ethernet
Communication configuration settings (from the System Configuration
screen).  The Ethernet configuration options (and example values) are:

Ether Address: 080009622842 (not configurable)
Analyzer name: HP16500B
Internet Address (IP): 15.6.253.106
Advanced Configuration
   Gateway Address: 15.6.248.1
   File Timeout: 1.5 s
   Subnet Mask: 255.255.248.0 (set automatically)

Common Problems
If you have LAN connection problems  
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If your HP E3492A is in use

When you try to connect an HP E3492A which is in use by someone else, a
dialog will pop up to tell you who is connected to it.  If the user is
"user@<ip_address>", the HP E3492A is in use by a PC;<ip_address> is the
LAN address of the PC which is connected.

Press "Cancel" to cancel the connection attempt. Press "Unlock" to
disconnect the previous user from the HP E3492A. Press "Connect" to
disconnect the previous user, and then attempt your connection again.

Note Pressing either "Unlock" or "Connect" will immediately disconnect the
previous user from the HP E3492A.

Common Problems
If your HP E3492A is in use
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If your HP 16500B is in use 

When you try to connect an HP 16500B which is in use by someone else, a
dialog will pop up to tell you who is connected to it. If the user is
"High-Speed@remote", the HP 16500B System Communication channels is
set to High-Speed SCSI instead of Ethernet. If the user is
"user@<ip_address>", the HP 16500B is in use by a PC;<ip_address> is the
LAN address of the PC which is connected. 

Press "Cancel" to cancel the connection attempt. Press "Unlock" to
disconnect the previous user from the HP 16500B. Press "Connect" to
disconnect the previous user, and then attempt your connection again. 

Note Pressing either "Unlock" or "Connect" will immediately disconnect the
previous user from the HP 16500B. 

Common Problems
If your HP 16500B is in use 
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If there is no source code in the PC Trace

window

To make the PC Trace window track the source code listing, you must:

Make sure the PC Trace is able to access the source code files.

The source code files should be located in the place where the PC Trace can
reach. First, the PC Trace looks in the location where object file is placed.
Then, it searches the list of directories in the Source View Settings dialog box.

Go to Source View Setting dialog box and verify that appropriate directories
are found in the source path entries. If not, enter Source Path Field the name
of the directory that contains the source file.

Common Problems
If there is no source code in the PC Trace window
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If it takes longer to copy trace data than you

expect

The PC Trace window allows you to store up to 64K states of trace data in a
text file. It takes approx. 60 minutes (on PC) or approx. 20 minutes (on WS)
for you, however, to store all of the 64K states of the trace data,  ruling you
out of performing other important operations. For this reason, we
recommend you to store only the necessary portion of the trace data in the
text file.

Common Problems
If it takes longer to copy trace data than you expect
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When it takes longer to program/erase flash

ROM than you expect 

Programming/erasing of the flash ROM takes a certain period of time as
summarized in the table shown below. Your system operates normally when it
looks as if it is in a hang-up, although you cannot perform any operation
before the completion of the programming/erasing operation.

Algorithm Programming

Time

Erasing Time Unit

AMD 5V
Embedded (8 bit)

19 <1 min/1Mbyte

AMD 5V
Embedded (8 bit)

26 <1 min/1Mbyte

Intel Quick Pulse
(8 bit)

12 17 min/1Mbyte

Intel Auto (8 bit) 15 <1 min/1Mbyte

Intel Auto (16 bit) 19 <1 min/1Mbyte

Note The values listed above are provided for your reference and are not not be
included in the specifications of this product.

Common Problems
When it takes longer to program/erase flash ROM than you expect 
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Installation

This chapter shows you how to install the PC Trace and other required
software.

• Installing the PC Trace (MS Windows)

• Installing the PC Trace (HP 9000/700)

• Installing the PC Trace (SunOS)

• Installing the PC Trace (Solaris)
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Installing the PC Trace (MS Windows)

The PC Trace is designed to run on a PC running MS Windows 3.1.

Your system is required to have:

• CPU: 486SX 33MHz or faster

• Free disk space: 10 Mbytes or more (excluding those for OS and
debugger)

• RAM: 12 Mbytes or more

To install the PC Trace on personal computers running MS Windows, take the
following steps:

• Step 1. Install Win32s

• Step 2. Install the PC Trace

Step 1. Install Win32s

This step is only necessary if your PC is running Windows 3.1.

Before installing the PC Trace, you must install the Win32s libraries from the
Microsoft Win32s Setup disks which are included with the PC Trace.

The PC Trace is a Microsoft Windows 32-bit application.  To run 32-bit
applications under MS Windows 3.1, the Win32s support libraries from
Microsoft must be installed on your system.

The PC Trace requires Win32s version 1.1 or later.

1 Start MS Windows in the 386 enhanced mode.

2 Insert the Microsoft Win32s Setup disk into floppy disk drive A or B.

Installation
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3 Choose the File→Run... (ALT, F, R) command in the Windows
Program Manager.  Enter "a:\setup" (or "b:\setup" if you installed the
floppy disk into drive B) in the Command Line text box.

Then, click on the OK button.  Follow the instructions on the screen.

The Win32s Setup will ask you to add SHARE.EXE to your AUTOEXEC.BAT
file.  You may do so if you wish; however, the PC Trace does not require you
to run SHARE.EXE.

Step 2. Install the PC Trace

1 Start MS Windows in the 386 enhanced mode.

2 Insert the PC Trace system disk into floppy disk drive A or B.

3 Choose the File→Run... (ALT, F, R) command in the Windows
Program Manager.  Enter "a:\setup" (or "b:\setup" if you installed the
floppy disk into drive B) in the Command Line text box.

Then, click on the OK button.  Follow the instructions on the screen.

Installation
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Installing the PC Trace (HP 9000/700)

This section shows you how to install the PC Trace on HP 9000 Series 700
computers running the HP-UX operating system.

The PC Trace requires:

• 6 Mbytes of hard disk space.

• HP-UX version 9.0 or greater.

• Motif 1.2.

• X11R5 X Window system.

Refer to the information on updating HP-UX in your HP-UX documentation
for instructions on installing software.  Generally the steps you take are those
shown below.

1 Become the root user on the system you want to update.

2 Make sure the tape’s write-protect screw points to SAFE.

3 Put the product media into the tape drive that will be the source

device for the update process.

4 Confirm that the tape drive BUSY and PROTECT lights are on.  If the
PROTECT light is not on, remove the tape and confirm the position
of the write-protect screw.  If the BUSY light is not on, check that the
tape is installed correctly in the drive and that the drive is operating
correctly.

5 When the BUSY light goes off and stays off, start the update program
by entering

/etc/update

at the HP-UX prompt.

Installation
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6 When the HP-UX update utility main screen appears, confirm that the
source and destination devices are correct for your system.  Refer to
the information on updating HP-UX in your HP-UX documentation if
you need to modify these values.

7 Select "Select All Filesets on the Source Media" when your source
and destination directories are correct.

8 To begin the update, press the softkey <Select Item>.  At the next
menu, press the softkey <Select Item> again.  Answer the last prompt
with

y

It takes several minutes to read the tape.

9 When the installation is complete, read /tmp/update.log to see the
results of the update.

10 Add "/usr/hpcol/hp700_9/bin" to your PATH environment variable.

11 To allow your X server to find the HP 16500B fonts, type:

/usr/bin/X11/xset +fp /usr/hpcol/hp700_9/lib/gsbpp

at the HP-UX prompt.

If you are using the HP Vue window manager, you may add the "xset"
command to the /usr/vue/config/Xstartup script to set up the font path each
time the X server is started.  If you are not using Vue, you may add it to your
$HOME/.profile file.

Installation
Installing the PC Trace (HP 9000/700)

5-6



Installing the PC Trace (SunOS)

System Requirements

This software is designed to run on a Sun SPARC system with SunOS version
4.1.3 or 4.1.3_U1 and OpenWindows 3.0.  The tape uses the QIC-24 data
format. 

Your system is required to have:

• 30 Mbytes of free disk space

• OpenWindows version 3.0 or greater

• SunSoft OSF/Motif version 1.2.2 or greater, or IXI Motif version 1.2.2 or
greater

To install the PC Trace on Sun workstations running the SunOS operating
system, you will take the following steps:

• Step 1. Mount the tape

• Step 2. Install the software

• Step 3. Run the configure script (if necessary)

• Step 4. Install the SunOS patches

• Step 5. Set the PATH environment variable

Installation
Installing the PC Trace (SunOS)
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Step 1. Mount the tape

1 Check that your tape drive can read QIC-24 tapes.

If you have a QIC-150 (Archive Viper), Emulex MT-02, or Sysgen SC4000
tape drive, it can read QIC-24 tapes.  4-track QIC-11 tape drives cannot read
9-track QIC-24 tapes.  

To find out what kind of tape drive you have, type:

mt -f <tape_device_name>  status

If your tape drive cannot read QIC-24 tapes, stop now and find another tape
drive.

2 Verify the HP  B3745A product tape’s write-protect screw points to
SAFE. 

3 Insert the tape in the tape drive, and slide the lever on the tape drive
to the right.

Installation
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Step 2. Install the software

1 Log in as root.

2 Extract the swa_install script from the tape.

If the tape drive is on your local system, type:

umask 0
cd /
tar xvfbp <device>  20

If you are installing the software from a tape drive which is on a remote
system, type:

cd /
rsh -n W0I< hostname >"dd if=W0I<device> bs=20b"| 
   tar xvfbp - 20

<device> is the name of your tape device. <hostname> is the name of the
system with the tape drive.

Installation
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Step 3. Run the configure script

• To run the configure script, you must change to the
usr/hpcol/sunos_4 directory:

cd usr/hpcol/sunos_4
./configure

The stand-alone configure script should be run on the workstation where
you originally installed the PC Trace and again on each workstation which
NFS mounts the usr/hpcol install tree (and has a local file system).  The
configure script may be run as root at any time to verify that all files
required by the PC Trace are linked to the correct locations on the local file
system.

The configure script does the following:

1 Installs the XKeysymDB file if the required OSF keymappings do not
exist in $OPENWINHOME/lib/XKeysymDB.

2 Installs two 16500B fonts in the $OPENWINHOME/lib/fonts directory.

$OPENWINHOME is /usr/openwin by default.

Installation
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Example Assume the HP B3745A product was installed on the file server snow_white

in the directory /home/snow_white.

There are seven workstations who want to share snow_white’s HP B3745A
install directory.  To share this directory, you must do the following for each
dwarf workstation:

1 Log in to the dwarf’s system as root.

2 Mount snow_white’s HP B3745A install directory:

mount snow_white:/home/snow_white/usr/hpcol /usr/hpcol

3 Change directories to /usr/hpcol/sunos_4, and run the configure
script to link the necessary HP B3745A files onto your local file
system.  The configure script is verbose and will tell you which files
failed to link.  Follow the instructions given by the configure script,
and keep re-running it until it succeeds.

cd /usr/hpcol/sunos_4
./configure

Installation
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Step 4. Install a SunOS patch

The HP B3745A product redistributes a SunOS patch that must be installed
before you can use the PC Trace:

• 100257-05: the "Jumbo ld patch" - fixes dynamic loader defects.  If you
have SunOS version 4.1.3_U1, you DO NOT have to install this patch.

This patch is located in its entirety under the
/usr/hpcol/sunos_4/patch_dir/<patch_number> directory.

• First, check with your system administrator to see if this patch has
already been installed.  If it has, skip to Step 5.  If not, change to the
appropriate patch directory, and follow the directions in the
README file carefully:

cd /usr/hpcol/sunos_4/patch_dir/<patch_number>
cat README

WARNING When installing the 100257-05 patch (specifically when installing the new
/usr/lib/ld.so library) follow the instructions in the README file precisely.
Make sure to log in as root, and check your SunOS revision by typing "uname
-r" to ensure the correct version of ld.so is being installed.

Note This patch must be installed on each Sun workstation which will run the PC
Trace.

Installation
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Step 5. Set the PATH environment variable

• Set the PATH environment variable to include the
/usr/hpcol/sunos_4/bin directory.

If you are using "csh", enter:

setenv PATH ${PATH}:/usr/hpcol/sunos_4/bin

If you are using "sh" or "ksh", enter:

PATH=${PATH}:/usr/hpcol/sunos_4/bin
export PATH

After setting PATH, type "r39pp" to start the PC Trace.

Installation
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Installing the PC Trace (Solaris)

System Requirements

This software is designed to run on a Sun SPARC system with SunOS version
5.3 (Solaris 2.3) or greater.  The tape uses the QIC-24 data format.  

In addition, your system must have:

• 8 Mbytes of free disk space

• OpenWindows version 3.0 or greater

• OpenWindows non-essential MIT core clients (package SUNWowMIT)

• OpenWindows optional fonts (package SUNWowoft)

• SunSoft OSF/Motif version 1.2.2 or greater, or IXI Motif version 1.2.2 or
greater

To install the PC Trace on Sun workstations running the SunOS operating
system, you will take the following steps:

• Step 1. Mount the tape

• Step 2. Install the software

• Step 3. Run the configure script (if necessary)

• Step 4. Set the PATH environment variable

Installation
Installing the PC Trace (Solaris)

5-14



Step 1. Mount the tape

1 Check that your tape drive can read QIC-24 tapes.

If you have a QIC-150 (Archive Viper), Emulex MT-02, or Sysgen SC4000
tape drive, it can read QIC-24 tapes.  4-track QIC-11 tape drives cannot read
9-track QIC-24 tapes.  

To find out what kind of tape drive you have, type:

mt -f <tape_device_name> status

If your tape drive cannot read QIC-24 tapes, stop now and find another tape
drive.

2 Verify the HP B3745A product tape’s write-protect screw points to
SAFE.

3 Insert the tape in the tape drive, and slide the lever on the tape drive
to the right.

Installation
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Step 2. Install the software

1 Log in as root.

2 Extract the swa_install script from the tape.

If the tape drive is on your local system, type:

cd /
umask 0
tar xvfbp <device>  20

If you are installing the software from a tape drive which is on a remote
system, type:

cd /
rsh -n < hostname >"dd if=< device > bs=20b"| 
   tar xvfbp - 20

<device> is the name of your tape device. <hostname> is the name of the
system with the tape drive. 

Installation
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Step 3. Run the configure script

• To run the configure script, you must change to the
opt/hpcol/solar_2 directory:

cd opt/hpcol/solar_2
./configure

• For the environmental variable HOME, specify the directory where
your Motif package software resides.

Example Set the environmental variable MOTIFHOME as follow:

setenv MOTIFHOME /opt/SUNWmotif
          (SunSoft OSF/Motif 1.2.2)
setenv MOTIFHOME /usr/dt
          (SunSoft OSF/Motif 1.2.3)
setenv MOTIFHOME /Motif1.2.2/usr
          (IXI Motif 1.2.2)

The stand-alone configure script should be run on the workstation where
you originally installed the PC Trace and again on each workstation which
NFS mounts the opt/hpcol install tree (and has a local file system).  The
configure script may be run as root at any time to verify that all files
required by the Software Analyzer are linked to the correct locations on the
local file system.

The configure script does the following:

1 Checks for the existence of the SunSoft OSF/Motif 1.2.2 or 1.2.3 product
under $MOTIFHOME. If $MOTIFHOME has not been defined, the script
looks under /opt/SUNWmotif (for Motif 1.2.2) or under /usr/dt (for Motif
1.2.3).

2 Installs two 16500B fonts in the $OPENWINHOME/lib/fonts directory.

$OPENWINHOME is /usr/openwin by default.

3 For SunSoft OSF/Motif 1.2.3 only, creates symbolic links between
versions 2 and 3 of the Motif shared libraries.

Installation
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Example Assume the HP B3740 product was installed on the file server snow_white in
the directory /home/snow_white.

There are seven workstations who want to share snow_white’s HP B3740
install directory.  To share this directory, you must do the following for each
dwarf workstation:

1 Log in to the dwarf’s system as root.

2 Mount snow_white’s HP B3740 install directory:

mount snow_white:/home/snow_white/opt/hpcol /opt/hpcol

3 Change directories to /opt/hpcol/solar_2, and run the configure script
to link the necessary HP B3740 files onto your local file system.  The
configure script is verbose and will tell you which files failed to link.
Follow the instructions given by the configure script, and keep
re-running it until it succeeds.

cd /opt/hpcol/solar_2
./configure
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Step 4. Set the PATH environment variable

• Set the PATH environment variable to include the
/opt/hpcol/solar_2/bin directory.

If you are using "csh", enter:

setenv PATH ${PATH}:/opt/hpcol/solar_2/bin

If you are using "sh" or "ksh", enter:

PATH=${PATH}:/opt/hpcol/solar_2/bin
export PATH

After setting PATH, type "r39pp" to start the PC Trace.
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Glossary  

browser A pop-up menu which lets you examine and select the local file. 

compile option An option necessary for generating symbol information.
Use "-g" for Greenhills C CROSS MIPS COMPILER/ASSEMBLER Ver. 1.8.7 or
later. Be sure to generate your object file WITHOUT optimization: If an
optimized object file is used, the PC Trace possibly fails in viewing a trace list
in a proper format.

database file The file created by the symbol utility and stored on the logic
analyzer’s internal hard disk.  The file is organized so that the Symbol Utility
can efficiently look up the symbol associated with any address or label value.
Database files have a ".NS" file name extension. 

language tool chain A set of programs used to generate executable code.
For example, a compiler, assembler, and linker. 

procedure This term is used in the Symbol Utility to refer to procedures,
functions, subroutines, or their equivalents. 

reader A program that generates a database file from a symbol file. 

symbol file A file which contains symbol information. This file is produced
by the language tool chain. 

Win32s A runtime library that allows 32-bit Windows applications to run in
Microsoft Windows 3.1. Win32s is provided by Microsoft.
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Index

! .ns files, 2-3

A ADDR label, 4-6 - 4-7
algorithm, programming, 3-16
assembler, 2-3

B bnc port, setting, 3-25
browser, 1-1

C command line options, 2-5
commands, main window, 3-3 - 3-10
commands, pc trace window, 3-11 - 3-28
common problems, 4-2
compile option, 1-1
compiler, 2-3
compress mode, viewing, 3-28
conditioned tracing, 3-20
configuration, 3-24 - 3-25
configuration, setting, 3-24
connecting to hp 16500b, 3-8
connecting to hp 16500b, problems, 4-3
connecting to hp e3492a, 3-6
Connection timeout, 3-6, 3-8
copying a trace list, 3-14
copying trace data, 3-15

D database file, 1-1
debug mode, message, 3-27
downloading executable file to hp e3492a, 3-12
downloading symbols to hp 16500b, 3-4

E elf file field, using, 2-3
elf files, downloading to hp 16500b, 3-4
elf files, downloading to hp e3492a, 3-12
elf load field, using, 2-3
elf symbol files, creating, 2-3
elf symbol files, loading, 2-3
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erasing flash ROM, 3-16, 4-8
error messages, 3-29 - 3-30
ethernet configuration options, 4-3
executable file, downloading to hp e3492a, 3-12
exeption, message, 3-27
exiting the processor probe, 3-5

F FLASH Operation, 3-16
flash ROM, erasing, 3-16
flash ROM, long time, 4-8
flash ROM, programming , 3-16

G glossary, 1-1 - 1-2

H halting tracing, 3-23
Hardware Break, 3-20
HP 16500B Trace List settings, 3-10
hp 16500b, connecting to, 3-8
hp 16500b, in use, 4-5
hp e3492a, connecting to, 3-6
HP E3492A, in use, 4-4

I If it takes longer to copy trace data than you expect, 4-7
If there is no source code in PC Trace window, 4-6
If your HP E3492A is in use, 4-4
in use status, 4-4 - 4-5
Instruction Address Break, 3-20

J jump/brance taken, message, 3-27

L LAN address, HP 16500B, 3-6, 3-8
lan connection problems, 4-3
language tool chain, 1-1
line numbers, 3-9 - 3-10
linker, 2-3
long time, copy trace data, 4-7

M main window commands, 3-3 - 3-28
message, debug mode, 3-27
message, exeption, 3-27
message, jump/brance taken, 3-27
message, mnemonic, 3-27
message, pipeline stall, 3-27
message, sequence, 3-27
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messages, 3-29 - 3-30
mnemonic, message, 3-27
mnemonic, viewing, 3-27

N non-realtime tracing, 3-23

O options, command line, 2-5
overview, ii-vi

P PATH environment variable, 5-6
pc trace window settings, 3-9
PC Trace window, no source code in, 4-6
PC Trace, installing, 5-2
ping command, 4-3
pipeline stall, message, 3-27
prerequisites, 1-2
prgramming flash ROM, 4-8
problems, common, 4-2
procedure, 1-1
Processor Bus Break, 3-20
processor probe, exiting, 3-5
programming algorithms, 3-16
programming flash ROM, 3-16
protocol, network, 3-6

R reader, 1-1
realtime tracing, 3-23
reference information, 3-2
requirements, 1-2

S sequence, message, 3-27
setting bnc port, 3-25
setting configuration, 3-24
setting, viewing in compress mode, 3-28
setting, viewing mnemonic, 3-27
setting, viewing source only, 3-28
setting, viewing source-mixed, 3-28
setting, viewing symbols, 3-26
settings, HP 16500B Trace List  window, 3-10
settings, pc trace  window, 3-9
source code, not in Source window, 4-6 - 4-7
source only, viewing, 3-28
source path, 3-9 - 3-10
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source-mixed, viewing, 3-28
symbol database, .ns files, 2-3
symbol file, 1-1
symbols, downloading to hp 16500b, 3-4
symbols, viewing, 3-26

T tab width, 3-9 - 3-10
timeout, connection, 3-6, 3-8
trace data, copying, 3-15
trace list, copying, 3-14
trace, about, 3-18
trace, after, 3-18
trace, again, 3-23
trace, always, 3-18
trace, before, 3-19
trace, conditioned, 3-20
trace, execute, 3-23
trace, halting, 3-23
trace, non-realtime mode, 3-23
trace, realtime mode, 3-23
tutorial, 1-2

W When it takes longer to flash ROM than you expect, 4-8
win32s, 1-1
Win32s, installing, 5-3
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